Idle adjust spring seems very stiff- anyone using a non OEM spring??
Close
    
    
Results 1 to 3 of 3
  1. #1
    Junior Member biker44's Avatar
    Join Date
    Apr 2014
    Posts
    24

    Idle adjust spring seems very stiff- anyone using a non OEM spring??

    On my 2010 TW, the idle adjustment takes a lot of effort to lower the idle speed. No problem increasing the idle speed, but difficult to lower. It seems like the spring gets caught of in the mounting hardware and it is very difficult to turn the adjustment knob . Wondering if anyone has found a spring that works better?

  2. #2
    rbm
    rbm is offline
    Senior Member rbm's Avatar
    Join Date
    Jan 2011
    Posts
    4,300
    Mine does the same thing, 2005.

  3. #3
    Junior Member biker44's Avatar
    Join Date
    Apr 2014
    Posts
    24
    I think I found the problem with my bike- I didn't put the washer back on the tip of the cable before threading into the carb. Mine seems a lot better now that I added the washer. do you have the spring on yours??

Sponosred Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Yay spring!
    By Mukluk in forum General Discussion
    Replies: 7
    Last Post: 04-03-2014, 05:59 AM
  2. Spring is here!...or somewhere...
    By Tirebiter in forum Off-Topic
    Replies: 32
    Last Post: 03-27-2014, 06:05 PM
  3. Will Spring ever come ?????
    By pair of jacks in forum Trails, Off-road, and Adventure Riding
    Replies: 6
    Last Post: 02-28-2014, 09:35 AM
  4. Replies: 8
    Last Post: 01-08-2014, 05:10 AM
  5. Is it spring yet?
    By wrench-puller in forum General Discussion
    Replies: 16
    Last Post: 03-13-2011, 07:13 PM