Ground or water damage issue?
Close
    
    
Results 1 to 5 of 5
Like Tree1Likes
  • 1 Post By docjekyll2002

Thread: Ground or water damage issue?

  1. #1
    Senior Member docjekyll2002's Avatar
    Join Date
    Aug 2013
    Location
    San Jose, CA
    Posts
    648

    Ground or water damage issue?

    I recently had my left rear blinker drown in a puddle while dual sporting. I found a loose connection on the right panel (white tab) and reconnected it, checked fuses, wiggled cables there and under rear fender. Still the left rear blinker is not working. The housing was cracked and the bulb was broken. I replaced the bulb. Still haven't taken the seat off to check cables yet? Any suggestions?

  2. #2

  3. #3
    Senior Member scotti158's Avatar
    Join Date
    May 2013
    Location
    Groton, NY
    Posts
    2,663
    Disconnect blinker and test with an ohm meter, also test bulb with meter to make sure it is good. I'm betting that something is broken in the socket itself, the meter will verify it (or not) but this would be a good place to start.
    2013 Yamaha TW200

    1996 Yamaha TW200

    1995 Kawasaki KLR650

    2002 Yamaha RoadStar 1600 with sidecar

  4. Remove Advertisements
    TW200Forum.com
    Advertisements
     

  5. #4
    Senior Member Fred's Avatar
    Join Date
    Dec 2011
    Location
    Turtle Wrangling the Sierras
    Posts
    18,702
    From corrosion visible on broken bulb I would expect to see similar white gook inside socket . Clean any corrosion inside socket and socket terminals. Check socket's ground and hot terminals with ohm meter if replaced bulb still doesn't illuminate.

  6. #5
    Senior Member docjekyll2002's Avatar
    Join Date
    Aug 2013
    Location
    San Jose, CA
    Posts
    648
    Had a neighbor's landlord help me today. He started playing with the cable hookups under the read fender and the turn signal now works! Might have been a loose connection or moisture issue.
    Fred likes this.

Sponosred Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. What's the Worst Damage You Did to Your TW?
    By scotti158 in forum General Discussion
    Replies: 20
    Last Post: 02-18-2014, 10:52 AM
  2. Dead in the water...
    By TW_in_BC in forum Technical Help
    Replies: 16
    Last Post: 10-28-2013, 09:37 PM
  3. Cheap soft ground Insurance
    By r80rt in forum Performance and Customization
    Replies: 0
    Last Post: 12-24-2012, 06:26 PM
  4. Damage while rejetting
    By dganey in forum Technical Help
    Replies: 6
    Last Post: 03-21-2012, 12:20 PM
  5. Need Wiring help, ground up
    By wdaloz in forum Technical Help
    Replies: 6
    Last Post: 09-30-2011, 01:26 PM

Tags for this Thread