LED turn signal problem
Close
    
    
Results 1 to 4 of 4
  1. #1
    Junior Member swmotdub200's Avatar
    Join Date
    Jun 2014
    Posts
    4

    LED turn signal problem

    So I just installed LED turn signals on my 2008TW and now have a malfunction I could use some help with. I did install an electronic flasher from superbrightled.com that pluged directly into my existing terminal. I also spliced in the diode kit per the directions "where the two wires come from the turn signal indicator light on the dash" I bought from ebay "Küryakyn 4709 Diode Kit for Metric Bikes with a Single Turn Signal Indicator Light on Dash".

    Now for my problem: The Right turn signals work correctly, however the left side stays on all the all the time but does blink when the signal switch is activated . The left side signals are dim until the switch is engaged and then is matches the brightness of the right. Also the signal dash light stays on a light at all times.

    Any help would be greatly appreciated. Thank You

  2. #2
    rbm
    rbm is offline
    Senior Member rbm's Avatar
    Join Date
    Jan 2011
    Posts
    4,300
    Try taking the diodes out, you shouldn't need them since you have the electronic flasher.

  3. #3
    Junior Member swmotdub200's Avatar
    Join Date
    Jun 2014
    Posts
    4
    So I removed the diode and that didn't work. Even with thw trun signal indicator bulb taken out of the loop I still have the same issue that started this thread. Anyone have any experience with the troubles I'm having? Any help would be appreciated.

    Thank You.

  4. Remove Advertisements
    TW200Forum.com
    Advertisements
     

  5. #4
    Senior Member oilhed's Avatar
    Join Date
    Jun 2014
    Location
    Central CT
    Posts
    486
    There is voltage leaking. If it's not a short somewhere it can be as simple as the flasher malfunctioning. I would put the original flasher and the diodes back in and see if it works.
    Mark Flanagan
    aka OILHED
    2014 Yamaha TW200 &
    2001 BMW R1150GS

Sponosred Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Turn signal mod question
    By wbpolk in forum Performance and Customization
    Replies: 5
    Last Post: 03-09-2014, 06:50 PM
  2. Turn Signal Problem
    By Borneo in forum Technical Help
    Replies: 8
    Last Post: 02-16-2014, 08:25 PM
  3. Turn signal indicator out?
    By TW200_CA in forum Technical Help
    Replies: 12
    Last Post: 12-26-2012, 04:54 PM
  4. WTB: OEM Turn Signal Indicators
    By joet3ch in forum TW200 Classifieds
    Replies: 0
    Last Post: 11-09-2011, 01:43 PM
  5. WTB - Turn signal lens.
    By the-wild-man in forum TW200 Classifieds
    Replies: 0
    Last Post: 11-04-2011, 08:30 AM

Search tags for this page

led turn signals

Click on a term to search for related topics.