1987 tw200 popping while idling
Close
    
    
Results 1 to 9 of 9
Like Tree1Likes
  • 1 Post By lude

Thread: 1987 tw200 popping while idling

  1. #1
    Junior Member lude's Avatar
    Join Date
    May 2015
    Posts
    6

    1987 tw200 popping while idling

    just picked up a tw tonight that had sat for a few years heard it run at the guys house but not long. said it had old gas in it and wasnt running right. i took his word for it. got home dug into it. changed the oil (was black as you can imagine) and put fresh gas in it. along with a new plug. now the bike starts easy and runs alright but while sitting and idling it will pop and spit once in awhile and want to die out. giving it gas doesnt really help either. is this likely the cdi? i know this year is bad for the cdi's going out. and was hoping the whole time i was picking the bike up that it would be one of the few that doesnt have the issue. no such luck. if it turns out to be the cdi. does anyone know what it will take to convert to the newer style? it already needs a new left side cover so it might be worth it to upgrade the whole system. funny how. "ready to ride" really means i need to dump another grand into the bike i feel like i over paid for already.. such is life though. any advice about any of this would be great.

  2. #2
    rbm
    rbm is offline
    Senior Member rbm's Avatar
    Join Date
    Jan 2011
    Posts
    4,300
    Hello and welcome! Before you jump to conclusions, add some Seafoam to the gas and run it for a while. Make sure to start it every day for a few with the seafoam in it to let it do it's thing. See if it clears up a bit, could be remnants of th old gas.

  3. #3
    Senior Member RockyTFS's Avatar
    Join Date
    Feb 2011
    Location
    Hailey, ID
    Posts
    3,341
    I don't think popping and spitting while idling can be caused by a bad CDI. Gas that has sat for a FEW YEARS is not just OLD, it's halfway back to being a dinosaur! You will need to go through the entire fuel system from gas cap to intake valve. Check the threads here on doing a proper tank and carb clean. You may not need to spend many $ at all, but a fair bit of time to do it really thoroughly. These carbs like being clean and properly set up....who knows what sort of clown worked on that old of a bike. Learn how to do this yourself. Also, on that old of a bike, especially if it has sat out, the intake snorkel may be rotted and leaking.

    Check the sticky "how to bring a sitting bike back to life" as well.

    Or just run some Seafoam like RBM said.....

    Dang it, I just take too long to do a carefully thought out reply and I'm an atrocious typist....
    Rocky
    2018 TW200
    2014 BMW R1200GS LC

  4. Remove Advertisements
    TW200Forum.com
    Advertisements
     

  5. #4
    Junior Member lude's Avatar
    Join Date
    May 2015
    Posts
    6
    Quote Originally Posted by RockyTFS View Post
    I don't think popping and spitting while idling can be caused by a bad CDI. Gas that has sat for a FEW YEARS is not just OLD, it's halfway back to being a dinosaur! You will need to go through the entire fuel system from gas cap to intake valve. Check the threads here on doing a proper tank and carb clean. You may not need to spend many $ at all, but a fair bit of time to do it really thoroughly. These carbs like being clean and properly set up....who knows what sort of clown worked on that old of a bike. Learn how to do this yourself. Also, on that old of a bike, especially if it has sat out, the intake snorkel may be rotted and leaking.

    Check the sticky "how to bring a sitting bike back to life" as well.
    doing my own work is not an issue i have been building custom bikes for years. just never a tw. when i drained the gas out it was actually not as bad as you would think. yellow forsure. but i got the bike on a little island up here in canada that doesnt use ethanol in the gas so it doesnt go as bad as fast. also speaking of clowns. the carb boot and filter boot are both slathered with silicone. so they will need to be replaced along with the plastics. seats mint though. somehow.

  6. #5
    Junior Member lude's Avatar
    Join Date
    May 2015
    Posts
    6
    also the bike only has 15000km so under 10000 miles.

  7. #6
    Senior Member Peterb's Avatar
    Join Date
    Apr 2011
    Location
    North Bay, Ontario, Canada
    Posts
    1,482
    When you say "pop and spit" are you talking out the intake or exhaust? Did you check the valve adjustment? Might be lean (try adding some propane from an unlit propane torch to the air intake under the seat and see if it smooths out) To see if its a flooding problem just shut the fuel off at the petcock and see if it runs better before it runs out of fuel. Lean is likely a dirty idle circuit in the carb (after you change that carb boot of course) Rich is likely a leaky needle and seat.
    BTW welcome from another Canadian TW owner

  8. #7
    Junior Member lude's Avatar
    Join Date
    May 2015
    Posts
    6
    so the bike wouldnt run at all yesterday when i tried. ended up taking the carb off. the carb boot was cracked and the oring was pinched. the valves were 12 thou loose on both the exhaust and intake so i reset them. cleaned blew out the carb, it looks great inside no gunk at all. super glued up the crack in the carb boot and put some rtv on the flange just to see if i could get it running again. and it started first kick running much better but still the odd miss. i took some advice and tried some propane in the intake of the carb. and it seemed to clear up and raise the idol a bit so i still have an air leak looks like. running lean. this was also without the filter boot on. it was rock hard and i had to pull it out to even get the carb in so it will also need to be replaced.
    Peterb likes this.

  9. #8
    Senior Member RockyTFS's Avatar
    Join Date
    Feb 2011
    Location
    Hailey, ID
    Posts
    3,341
    Quote Originally Posted by lude View Post
    ...... the valves were 12 thou loose on both the exhaust and intake so i reset them.......
    Wow! THAT'S LOOSE!!! That thing musta sounded like a train going clickety-clack down the track....

    Seems like you're on the right track.
    Rocky
    2018 TW200
    2014 BMW R1200GS LC

  10. #9
    Junior Member lude's Avatar
    Join Date
    May 2015
    Posts
    6
    Quote Originally Posted by RockyTFS View Post
    Wow! THAT'S LOOSE!!! That thing musta sounded like a train going clickety-clack down the track....

    Seems like you're on the right track.
    it had some clatter forsure. its still going to need some work, but at this point i think its just an air leak. but im still considering swapping the side cover and electronics to the later ones just incase and to replace my side cover with a big hole in it

Sponosred Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Popping and not pulling, carb troubleshoot? Help!
    By SDTW200 in forum Technical Help
    Replies: 6
    Last Post: 09-13-2014, 10:14 AM
  2. Suddenly started popping
    By 1RobAusdemore in forum Technical Help
    Replies: 6
    Last Post: 09-08-2014, 11:21 PM
  3. Backfiring / Popping downhill?
    By twTimG in forum Technical Help
    Replies: 5
    Last Post: 07-14-2014, 07:13 PM
  4. low rpm idling when warning up
    By Schmitty in forum Technical Help
    Replies: 21
    Last Post: 03-30-2014, 08:10 AM
  5. Popping sound at half throttle
    By TWBARR in forum Technical Help
    Replies: 12
    Last Post: 09-28-2011, 11:09 AM