Idles fine, but when i give it gas all it does is backfire.
Close
    
    
Results 1 to 8 of 8
Like Tree3Likes
  • 1 Post By Motard
  • 1 Post By Dubster
  • 1 Post By littletommy

Thread: Idles fine, but when i give it gas all it does is backfire.

  1. #1
    Junior Member Motard's Avatar
    Join Date
    Jun 2015
    Location
    Ontario, Canada
    Posts
    5

    Unhappy Idles fine, but when i give it gas all it does is backfire.

    I have had my teedubb for a few weeks now and it has always ran great, until about a week ago when i got back from a long day of riding. I hopped on the bike, and it started and idled fine. But when i gave the bike gas all it did was spit and spudder and pop. Since then i have cleaned my gas tank (there was rust), i cleaned my carb out, changed the spark plug. Still, same problem. What could be going on, i will be rebuilding my carb tomorrow with a kit and hopefully that works. But some friends have suggested that maybe the valve timing is off, but i dont know.

  2. #2
    Super Moderator littletommy's Avatar
    Join Date
    Mar 2013
    Location
    Thankful for all of my friends!!
    Posts
    17,625
    Either you did break something or the pilot jet has gotten some debris in there clogging it up.
    1st John 1:9
    If we confess our sins, He is faithful and just to forgive us our sins, and to cleanse us from all unrighteousness.

    John 3:16
    For God so loved the world, that he gave his only begotten Son, that whosoever believeth in him should not perish, but have everlasting life.

    John 3:17
    For God sent not his Son into the world to condemn the world; but that the world through him might be saved.

    Hidden Content <<<Click here. Hidden Content

  3. #3
    Senior Member Rickhem's Avatar
    Join Date
    Nov 2014
    Location
    Schoharie County, NY
    Posts
    111
    I recently resurrected a 650 V-Star that had been submerged. After getting everything nice and dry, and completely disassembling and cleaning the carbs, and changing the gas, and all the other stuff that needed to be done first, I got it idling nicely. I had all the intake plenums removed and just set the tank on it to make sure it would run, and then I tried taking a little ride around my apartment complex with it. It ran fine at idle, but would cough and choke and spit and sputter whenever I applied throttle. After some thought, I tried putting all the intake stuff back on with the exception of the air filter. Night and day difference. It pulled hard from idle to redline. The point I'm trying to make is that a lot of things that seem like carb problems actually end up being other things.......like vacuum leaks, or just plain too much air for the system.

    To check for vacuum leaks, start the bike and let it idle, then spray some carb cleaner around by the area between the carb and the cylinder head. If there is a vacuum leak, you'll hear the idle change. Then you'll have to find where the leak is, which sometimes isn't easy. ;-)
    2009 TW200
    2000 V-Star Classic
    1986 HD Sportster (sold)
    1975 Yamaha DT125 (sold)

  4. Remove Advertisements
    TW200Forum.com
    Advertisements
     

  5. #4
    Junior Member Motard's Avatar
    Join Date
    Jun 2015
    Location
    Ontario, Canada
    Posts
    5
    I really am just baffled, i don't know what it could be. I checked for vacuum leaks, nothing.

    And the weird thing is its a hit or miss, sometimes it does it, other times it doesn't. Like sometimes when i first start the bike it runs good, revs perfectly, no issues. Then i go put my gear on and let it idle, come back and its just spitting and sputtering when i give it gas.

    I really just don't know what it could be, rebuilt the carb completely, checked for vacuum leaks, changed spark plug, only thing it could be is valves or the fact that my battery is completely dead.

  6. #5
    Super Moderator littletommy's Avatar
    Join Date
    Mar 2013
    Location
    Thankful for all of my friends!!
    Posts
    17,625
    What year bike is this?
    1st John 1:9
    If we confess our sins, He is faithful and just to forgive us our sins, and to cleanse us from all unrighteousness.

    John 3:16
    For God so loved the world, that he gave his only begotten Son, that whosoever believeth in him should not perish, but have everlasting life.

    John 3:17
    For God sent not his Son into the world to condemn the world; but that the world through him might be saved.

    Hidden Content <<<Click here. Hidden Content

  7. #6
    Junior Member Motard's Avatar
    Join Date
    Jun 2015
    Location
    Ontario, Canada
    Posts
    5
    Its an 87.
    littletommy likes this.

  8. #7
    Senior Member Dubster's Avatar
    Join Date
    Dec 2011
    Location
    Nova Scotia Canada
    Posts
    583
    Tommy are you thinking what I'm thinking?? Possible CDI failure.

    Motard the 87 model year had problems with the CDI. Hopefully it is something else because another CDI doesn't come cheap.
    LittleTommy"s TW is an 87 and he can probably offer more input than I.
    Good luck dude.
    littletommy likes this.
    09 DL650 V-Strom "Function over Form at a Superior Price"
    09 DR650 "Hooliganizer"
    03 TW200 "No Road---No Problem"
    81 Z50 "Just Because"
    98 Honda Valkyrie "Fast as [email protected]&K"
    02 Tw200 " Camouflaged Redneck Edition" Sold to Son-in-Law
    73CT Trail90 "The most fun you can have under 100cc's" Sold. Had an offer I couldn't refuse.

  9. #8
    Super Moderator littletommy's Avatar
    Join Date
    Mar 2013
    Location
    Thankful for all of my friends!!
    Posts
    17,625
    Quote Originally Posted by Dubster View Post
    Tommy are you thinking what I'm thinking?? Possible CDI failure.

    Motard the 87 model year had problems with the CDI. Hopefully it is something else because another CDI doesn't come cheap.
    LittleTommy"s TW is an 87 and he can probably offer more input than I.
    Good luck dude.
    Dubster, I am now since now we know the year. +1

    https://tw200forum.com/forum/technica...check-cdi.html
    Here you go Motard. There are many useful things found in the technical write up section (at the very top) of the technical help part of the forum.

    Here is another link in the section that every new member should read as soon as they join also.
    https://tw200forum.com/forum/technica...tech-tips.html

    Keep us posted Motard, your solution should be in these somewhere.

    *Reminder: When asking for help, always let us know the year....
    jeffrolives likes this.
    1st John 1:9
    If we confess our sins, He is faithful and just to forgive us our sins, and to cleanse us from all unrighteousness.

    John 3:16
    For God so loved the world, that he gave his only begotten Son, that whosoever believeth in him should not perish, but have everlasting life.

    John 3:17
    For God sent not his Son into the world to condemn the world; but that the world through him might be saved.

    Hidden Content <<<Click here. Hidden Content

Sponosred Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. TW 200 idles fine but cannot give it throttle?
    By cmercon in forum Technical Help
    Replies: 8
    Last Post: 06-24-2015, 06:59 AM
  2. backfire
    By Skipper in forum Technical Help
    Replies: 2
    Last Post: 10-24-2014, 08:46 PM
  3. Idles fine, then sputters when I give it the gas
    By PSLADE in forum Technical Help
    Replies: 2
    Last Post: 08-21-2014, 04:00 AM
  4. petcock...pilot screw...and backfire....
    By robalo in forum Technical Help
    Replies: 24
    Last Post: 12-09-2013, 05:05 AM
  5. Bike idles fine on stand, dies when upright
    By Sloppy in forum Technical Help
    Replies: 14
    Last Post: 07-07-2011, 08:28 PM