Turn signal switch not functioning.
Close
    
    
Results 1 to 9 of 9
  1. #1
    Junior Member 47sgs's Avatar
    Join Date
    Jun 2011
    Posts
    4
    I'm new to this forum, but was relieved to find it, and am hopeful for some help. My older TW200, a 1987, is having trouble with the turn signal switch. The last couple months, the left signal worked very hard and felt gummed up, then quit working. The right turn switch worked until yesterday, though it still moves freely to the right and cancel position okay. Can the switch inside the housing be cleaned, repaired, or replaced, or does the whole unit have to be replaced? Can I open it to see what's going on? If the whole housing unit needs to be replaced, where is a good place to look for the parts? Thanks so much for the help.

  2. #2
    Senior Member jontow's Avatar
    Join Date
    Oct 2010
    Location
    Potsdam, NY
    Posts
    701
    Perfectly safe to take it off and split it open.. I haven't lost any parts yet!



    You might find that its a simple solution if you do; and maybe some of the spray-type electrical contact cleaner and a small soft brush could help.
    --

    1997 TW, well loved, a bit modified.

  3. #3
    Banned qwerty's Avatar
    Join Date
    Jul 2010
    Location
    NW Tennessee
    Posts
    10,664
    My experiences with handlebar switches is you have a 20% shot of fixing it. The innards of handlebar switches tend to be fragile and succumb to dirt building up. Easy to clean with a bit of electrical contact cleaner or Seafoam Deep Creep. Sometimes when a switch stops making contact you can bend one of the contacts enough to make it work, but quite often the parts are brittle and break. If it can be bent enough to work it usually doesn't take long to unbend itself and stop working again. Consider a repair a temporary fix and start saving up for a replacement. A new switch will run about $150-175 online, with a $203 list price. Reason enough to attempt a repair and hit up eBay for a good used part eBay.



    2JX-83973-01-00 is the part number you want. It supersedes the original 2JX-83973-00-00 part number. Unfortunately, these part numbers were only used on early TWs (up until 2000), but I'm reasonably sure the difference between it and some other yamaha switches is nothing but the length of the wiring pigtail. Might want to check a bike salvage if you have access.



    Another option is to go with an aftermarket switch. Baja Designs makes a good one that sells for $55. It also has an engine kill function. You can cut the pigtail off your old switch and make it all work with the stock harness. I think the Baja Designs switch is really a relabeled K&S Technologies product.




  4. Remove Advertisements
    TW200Forum.com
    Advertisements
     

  5. #4
    Junior Member 47sgs's Avatar
    Join Date
    Jun 2011
    Posts
    4
    I went out and fiddled with the switch again. If I push down hard and right, the right signal comes on, and with effort, it will cancel. A couple times, if I pushed down and left, I could get the left signal to come on. It was much harder to do than right, and was difficult to cancel.

  6. #5
    Senior Member PJungnitsch's Avatar
    Join Date
    Jul 2010
    Location
    1996 TW200 Edmonton, AB
    Posts
    590
    Have you tried just spraying it from the outside with WD-40? On my old streetbike I had to do that once or twice a year (used the straw to get the WD inside as much as possible and then worked the switch a few times).

  7. #6
    Member TWiumph's Avatar
    Join Date
    Nov 2011
    Location
    N.Georgia, USA
    Posts
    68
    Quote Originally Posted by qwerty View Post
    ...Another option is to go with an aftermarket switch. Baja Designs makes a good one that sells for $55. It also has an engine kill function. You can cut the pigtail off your old switch and make it all work with the stock harness. I think the Baja Designs switch is really a relabeled K&S Technologies product.


    I'm not happy with the "action" of my turn signal switch, either.

    Would any of these K&S switches be a direct replacement for our stock switch? Is there another source for a TW200 specific aftermarket switch that a member has used successfully?
    2008 TW200: 14T/47T, 122-link KMC O-Ring Chain, Jimbo C Shield, wide pegs, factory rear rack, Pro Taper ATV High bars, G2 handguards, MSR shift lever, QuadBoss saddlebags.

    I do not own any stock and I do not owe anyone anything, except perhaps an open mind.

  8. #7
    Senior Member lizrdbrth's Avatar
    Join Date
    Jul 2010
    Location
    Desert, SoCal
    Posts
    7,369
    The early switches are completely rebuildable. Take it apart inside a box, because there is one small spring which could be lost the first time you disassemble yours. Clean the contacts lightly, lube the slide with some dielectric grease and you're good to go for 10 more years.



    The late switch is more complicated and less durable. But it can be monkeyed with, as well.



    I can explain it to you, but I can't understand it for you.

    Powdercoated '87 frame, extended swingarm, YZ fork legs, ATV tire, 14/55, XT350 tank, spliced quick-release seat, disc brake conversion, beeg headlight, beeger rack, Lizrdcooler, Lizrdventz and bunch of other stuff all covered in invisible ink.

    Hidden Content

    Hidden Content

  9. #8
    Senior Member Henrici's Avatar
    Join Date
    Sep 2010
    Location
    Big Island, HI
    Posts
    180
    Mines newer and I've had to disassemble and clean the contacts on a couple. Pretty simple figure out... I don't think you have much to loose if you do decide to try.

  10. #9
    Junior Member whjenks's Avatar
    Join Date
    Jun 2012
    Posts
    1
    I've got a 2003 model TW200. I only have about 7,000 miles on it, but my turn signal recently developed some issues. I activated the turn signal and couldn't get it to clear normally. After dismantling it and getting the internal components moving more freely, I reassembled it, fully expecting it to work. If I activate the right turn signal, I can turn and then clear the signal fine, but if I activate the left turn it cannot be cleared with the normal straight in push of the button. I end up have to push the signal over towards the right signal position. Anyway, I looked up the part which is 4CS-83973-00-00 which runs around 95 dollars or so. I wouldn't mind replacing it with the OEM part, but since my original only lasted 7,000 miles it might be discouraging to see a new one only last a few years. I think a switch with a 3-position toggle would be a simpler mechanism. Has anyone had any success with a particular after-market turn signal? Thanks for your help.

Sponosred Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. WTB handle bar turn signal and light switch
    By maxvic in forum TW200 Classifieds
    Replies: 0
    Last Post: 05-25-2013, 04:31 AM
  2. Turn signal indicator out?
    By TW200_CA in forum Technical Help
    Replies: 12
    Last Post: 12-26-2012, 04:54 PM
  3. LED turn signal heads up
    By operose in forum Technical Help
    Replies: 5
    Last Post: 03-24-2012, 09:33 AM
  4. WTB: OEM Turn Signal Indicators
    By joet3ch in forum TW200 Classifieds
    Replies: 0
    Last Post: 11-09-2011, 01:43 PM
  5. WTB - Turn signal lens.
    By the-wild-man in forum TW200 Classifieds
    Replies: 0
    Last Post: 11-04-2011, 08:30 AM

Search tags for this page

baja designs turn signal not working
,
blinker switch tw200
,

lubricate turn signal switch yamaha

,
replace ment turn signal switch yamaha
,

signal turn switch

,

tw200 turn signal not flashing

,
tw200 turn signal switch
,
yamaha tw 200 signal wont work
,

yamaha tw200 turn signal switch

Click on a term to search for related topics.