im starting to hate my tw
Close
    
    
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Senior Member dizzle2's Avatar
    Join Date
    Jun 2011
    Location
    olympia, wa
    Posts
    120
    ive done almost everything now. new carb parts 117.5 main jet. new needle and seat. carb is 100% clean. i am pretty sure it is the cdi unit. it runs rough and sputtery, almost like a lean issue, but i know it is not because i have a brand new spark plug in it and it has black on it because ive been trying to fatten the hell out of it. it backfires when let off the throttle. im not sure anymore here!? the engine is sound. it have better than factory compression and the valves looked amazing. ive been chasing my problem as a carb issue but i think im going to have to go the more expensive route with a cdi. any suggestions on where to get one for cheap and fast, how to test for it. etc? it is a 1987

  2. #2
    Senior Member uktw125's Avatar
    Join Date
    Jul 2010
    Location
    Devon, England.
    Posts
    614
    Are you certain you do not have an air leak in the carb to head rubber manifold.

    An '87 is susceptible to CDI problems though as you know.

  3. #3
    Senior Member demarko69's Avatar
    Join Date
    Feb 2011
    Posts
    540
    If you are 100% sure its not the carb then move on.

    There are oodles of possibilities of failure before the cdi... Test test test before spending 300+ on a new cdi

    Have you gone thru the entire electical system. By that i mean everything, wire shorts wire opens wire connectors wire switches key/ignition wire coil wire relays. Once everthing has been tested good and eliminated, then move on. In the past 4 months I have had 3 87 and not a 1 was running poorly due to the cdi. The one time I was sure it was the cdi, I changed it with a known good runnig 87 cdi and thought that fixed the problem. Turns out it was a broken wire inside a connector and when I change the cdi the wire remade contact due to the movement location. Another 87 had a kill switch intermittent problem. Everytime the bike was a a certian RPM it cutout miss & pop. Faster / slower was OK. The RPM made a resonant freq./vibration that was enough to make contact.



    ps. still curious on the yamaha 117.5 jet. Did you get a mfg/part# on the packing list

    ps.. the only way to test a 87 cdi is to swap it to a known running 87

    ps...if you want help bring it over, I have lots of 87 parts

  4. Remove Advertisements
    TW200Forum.com
    Advertisements
     

  5. #4
    Banned qwerty's Avatar
    Join Date
    Jul 2010
    Location
    NW Tennessee
    Posts
    10,664
    Quote Originally Posted by demarko69 View Post
    ps.. the only way to test a 87 cdi is to swap it to a known running 87

    ps...if you want help bring it over, I have lots of 87 parts
    That's the great thing about this forum.



    I don't think a CDI problem will cause a backfire if it runs right the rest of the time.



    I don't think Yamaha sells a 117.5 main jet in this series.



    288-14343-57-00 #114

    288-14343-58-00 #116

    288-14343-59-00 #118

    288-14343-60-00 #120



    It is a common problem that the numbers on jets from other sources do not flow the same as the Yamaha jets. I highly recommend Yamaha jets so we are all talking the same language. Then raise the needle and open the pilot screw a bit to richen the carb when the throttle is closed, which is the lean condition that causes popping in the exhaust.



    If you still think the problem is electrical, have you followed the troubleshooting procedures outlined in the repair manual?




  6. #5
    Senior Member secretStash's Avatar
    Join Date
    Jun 2011
    Posts
    116
    Refer to pages 7 dash 5 through 7 dash 13 of your Yamaha Service Manual.

    There is no way to test the CDI itself (that they state). Simply says at

    the end of that section that if everything they tell you to test checks

    out, then the problem is a faulty CDI.



    -sS

  7. #6
    Senior Member lizrdbrth's Avatar
    Join Date
    Jul 2010
    Location
    Desert, SoCal
    Posts
    7,369
    ...---...



    I can explain it to you, but I can't understand it for you.

    Powdercoated '87 frame, extended swingarm, YZ fork legs, ATV tire, 14/55, XT350 tank, spliced quick-release seat, disc brake conversion, beeg headlight, beeger rack, Lizrdcooler, Lizrdventz and bunch of other stuff all covered in invisible ink.

    Hidden Content

    Hidden Content

  8. #7
    Senior Member demarko69's Avatar
    Join Date
    Feb 2011
    Posts
    540
    Quote Originally Posted by lizrdbrth View Post
    ...---...
    ???

    I dont speak giberrish

  9. #8
    Senior Member Gerry's Avatar
    Join Date
    Jul 2010
    Location
    Paradise, Calif.
    Posts
    3,513
    S.O.S ? Gerry
    Take care my Friend.........

  10. #9
    Senior Member demarko69's Avatar
    Join Date
    Feb 2011
    Posts
    540
    Quote Originally Posted by mrgizmow View Post
    S.O.S ? Gerry


    thx

    I saw dot dot dot bar dot dot dot, I guess I need to put on my glasses

  11. #10
    Senior Member dizzle2's Avatar
    Join Date
    Jun 2011
    Location
    olympia, wa
    Posts
    120
    im just going to take it in to the dealer. he said $80+ tax and he will tell exactly what electrical component is the problem/if there is a problem. im just exhausted with testing and replacing with no luck. it is a 87' but i didnt expect this kind of problem. i mean it only has 7,700 miles on it. before droping $300 on a part it might not need im gunna take it in to find out for certain what is the problem. thx guys

Page 1 of 2 12 LastLast

Sponosred Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. I hate you all
    By maddawgj in forum General Discussion
    Replies: 15
    Last Post: 06-15-2013, 10:33 AM
  2. don't hate me
    By operose in forum Off-Topic
    Replies: 14
    Last Post: 09-30-2012, 07:21 PM
  3. The 1 thing I hate about the TW200
    By ceramite in forum General Discussion
    Replies: 21
    Last Post: 12-18-2011, 01:50 AM
  4. I Hate Weight Plates
    By TuggerHiller in forum General Discussion
    Replies: 10
    Last Post: 11-12-2011, 12:03 AM
  5. I Hate It When She's Right...
    By Kev250R in forum General Discussion
    Replies: 4
    Last Post: 07-18-2011, 10:34 PM

Search tags for this page

how test cdi

Click on a term to search for related topics.