turn signals
Close
    
    
Results 1 to 5 of 5

Thread: turn signals

  1. #1
    Member tw200_87's Avatar
    Join Date
    Jul 2010
    Posts
    62
    Well I finally put a new battery in the TW as I'm riding it on the road a lot more now and getting tired if using hand signals. The right side blinkers work fine but the left side does nothing.. The turn signal indicator for left turn just stays on. What's funny is that even though the right side blinkers work the indicator light does nothing. refresh my memory isn't it suppose to blink too? Bulbs are good. I do get .4v at the sockets when I turn the left side blinkers on. I suspect either a broken switch or broken wire. I really haven't spent any time trouble shooting yet but thought i would get some ideas from the forum group. Any ideas on what is wrong?



    Kevin

  2. #2
    Banned qwerty's Avatar
    Join Date
    Jul 2010
    Location
    NW Tennessee
    Posts
    10,664
    I'd chase wires and make sure everything is clean and plugged in. Check for 12V coming from the switch where the wires from the lights meet the wires from the switch.




  3. #3
    Member tw200_87's Avatar
    Join Date
    Jul 2010
    Posts
    62
    Just and update... the rear had a break in the wire to the left turn signal and the front left bullet connector had come appart.. Easy fix. All is well now

  4. Remove Advertisements
    TW200Forum.com
    Advertisements
     

  5. #4
    Banned qwerty's Avatar
    Join Date
    Jul 2010
    Location
    NW Tennessee
    Posts
    10,664
    Feels good, eh?




  6. #5
    Member tw200_87's Avatar
    Join Date
    Jul 2010
    Posts
    62
    yep, 24 year old bike and it's the first problem I had with it LOL



    Guess I can't complain too much..

Sponosred Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Rear Turn Signals
    By philp38 in forum Technical Help
    Replies: 17
    Last Post: 06-20-2019, 11:29 AM
  2. Turn signals
    By yz250f4ever in forum Performance and Customization
    Replies: 35
    Last Post: 03-16-2015, 03:15 PM
  3. ***FOUND***WTB Front turn signals
    By rbm in forum TW200 Classifieds
    Replies: 2
    Last Post: 05-09-2013, 05:11 PM
  4. Lighten, brighten turn signals
    By lizrdbrth in forum Performance and Customization
    Replies: 9
    Last Post: 02-15-2012, 08:45 PM
  5. Wiring front turn signals
    By SigepKat in forum Technical Help
    Replies: 3
    Last Post: 07-18-2011, 02:27 PM

Search tags for this page

front turn signal velcro

Click on a term to search for related topics.