Aftermarket Speedo/Neutral Switch Problem
Close
    
    
Results 1 to 6 of 6
Like Tree10Likes
  • 1 Post By DrTerrible
  • 1 Post By DrTerrible
  • 3 Post By grewen
  • 4 Post By DrTerrible
  • 1 Post By DrTerrible

Thread: Aftermarket Speedo/Neutral Switch Problem

  1. #1
    Senior Member DrTerrible's Avatar
    Join Date
    Jun 2016
    Location
    Sherwood Park, AB
    Posts
    273

    Aftermarket Speedo/Neutral Switch Problem

    So my TW had a broken speedo so got one from eBay for a price that was good. Has LEDs and looks good if you ask me. So when I was wiring it up and testing things out, I noticed that my neutral light would not go out when I put it in gear. From what I have read, the sky blue leads to the relay/switch/meter light. When I test the connection from the switch to the connection under the seat, I get no reading when it is in neutral. Is that supposed to be hot like the others if its in neutral?I did have the cover off and I'm 99% sure I didn't pinch the wire. Should I bite the bullet and take the cover back off, test the switch and order another gasket? And the switch if needed? I don't have the clutch or kickstand on right now but I don't think that would make the neutral light stay on. I think I pinched the wire or bad neutral switch.

    I hate electrical stuff
    jtomelliott49 likes this.

  2. #2
    Senior Member DrTerrible's Avatar
    Join Date
    Jun 2016
    Location
    Sherwood Park, AB
    Posts
    273
    Well after tearing the side cover off I am led to believe it is the neutral switch. There is power running to it but when I put it in gear there is still power to it. Will order one and report back.
    jtomelliott49 likes this.

  3. #3
    Senior Member grewen's Avatar
    Join Date
    Oct 2014
    Location
    Armstrong BC
    Posts
    2,379
    when you put one side of the meter to ground and the other lead to the neutral switch ( disconnected from bike wiring) and set the meter to ohms. does the readings change when shifting from neutral to any gear?
    Greg

    2019 honda cb500x
    2018 honda grom
    2018 suzuki dr200

  4. Remove Advertisements
    TW200Forum.com
    Advertisements
     

  5. #4
    Senior Member DrTerrible's Avatar
    Join Date
    Jun 2016
    Location
    Sherwood Park, AB
    Posts
    273
    Plunger broken on neutral switch...fixed

    I got 99 problems but a neutral switch ain't one

  6. #5
    Senior Member supachip1's Avatar
    Join Date
    Apr 2013
    Posts
    385
    did the light go out or still on? if its still on it is because the neutral switch breaks the ground not the live, I've only found 1 speedo with LED's that will work so far

  7. #6
    Senior Member DrTerrible's Avatar
    Join Date
    Jun 2016
    Location
    Sherwood Park, AB
    Posts
    273
    No it works now that I replaced the neutral switch. On when in neutral, off in gear.
    littletommy likes this.

Sponosred Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Neutral switch
    By LuvNot in forum Technical Help
    Replies: 7
    Last Post: 11-23-2017, 06:38 PM
  2. Neutral Switch Gremlin? Should I Ditch the Relay?
    By babetheblueox in forum Technical Help
    Replies: 2
    Last Post: 10-31-2016, 02:40 PM
  3. My first problem-neutral light
    By Michael Bryce Winnick in forum Technical Help
    Replies: 8
    Last Post: 03-23-2016, 04:52 PM
  4. Neutral Switch Problem?
    By adaulton in forum Technical Help
    Replies: 12
    Last Post: 08-09-2015, 07:09 AM
  5. Is this the Neutral switch and where does it plug into?
    By kemp.darryl in forum Technical Help
    Replies: 4
    Last Post: 09-02-2014, 05:40 AM