Tappet cover leaking
Close
    
    
Results 1 to 7 of 7
  1. #1
    Senior Member Guitarman's Avatar
    Join Date
    Jan 2012
    Location
    Trois-Rivieres, Canada
    Posts
    167
    I just want to let you know that I had a leak from my exhaust side tappet cover at only 6000 kms. I changed the seal and everything is back to normal.



    Keep an eye on yours, mine was leaking really badly.



    Cheers ;-)

  2. #2
    Super Moderator goldenhtr's Avatar
    Join Date
    Jul 2010
    Location
    Stanwood,Wa
    Posts
    1,898
    Quote Originally Posted by Guitarman View Post
    I just want to let you know that I had a leak from my exhaust side tappet cover at only 6000 miles. I changed the seal and everything is back to normal.



    Keep an eye on yours, mine was leaking really badly.



    Cheers ;-)


    Just noticed mine as well at 8000 miles. replaced mine as well just the other day.
    A very very wise man once said “it’s more fun to ride a slow bike fast, than a fast bike slow”.

    "Now then get your weapons... and go out to the open country to hunt some wild game for me"
    Gen:27:3

    “I've noticed that everyone who is for abortion has already been born.”
    -Ronald Reagan

  3. #3
    Senior Member TW_in_BC's Avatar
    Join Date
    Jul 2010
    Location
    BC
    Posts
    653
    Ditto...for some time now.

    Replacing the O-ring solved the problem.
    2008 TW200
    Southwest corner of BC Canada

    YouTube channel: Hidden Content

  4. Remove Advertisements
    TW200Forum.com
    Advertisements
     

  5. #4
    Senior Member elime's Avatar
    Join Date
    Jul 2010
    Location
    San Jose, CA
    Posts
    6,981
    I replaced the valve cover o-rings 4,000 miles ago. The other day I adjusted the valves and noticed the o-rings were starting to go flat. Normally I would have changed them but I am really curious how long they will last. These are non-Yamaha bought at a local place that specializes in different kinds of seals and gaskets and o-rings.



    Did you guys use genuine Yamaha o-ring?

    Long live the internal combustion engine!

  6. #5
    Senior Member TW_in_BC's Avatar
    Join Date
    Jul 2010
    Location
    BC
    Posts
    653
    I use ordinary 1 1/4" O-rings with roughly the same size cross-section. They cost me 40 cents each at the local machine shop. The original (exhaust side) lasted about 30,000 km before it needed replacing...and I check my valves often!



    I have more problems with the valve cover screws! Stripped one on the exhaust side a while back and had to replace it with a stud...now, I have another one on the exhaust side that feels "stripped" as well!
    2008 TW200
    Southwest corner of BC Canada

    YouTube channel: Hidden Content

  7. #6
    Senior Member elime's Avatar
    Join Date
    Jul 2010
    Location
    San Jose, CA
    Posts
    6,981
    Quote Originally Posted by TW_in_BC View Post
    I use ordinary 1 1/4" O-rings with roughly the same size cross-section. They cost me 40 cents each at the local machine shop. The original (exhaust side) lasted about 30,000 km before it needed replacing...and I check my valves often!



    I have more problems with the valve cover screws! Stripped one on the exhaust side a while back and had to replace it with a stud...now, I have another one on the exhaust side that feels "stripped" as well!


    You are tightening them to much! IMHO

    I tighten mine, compressing the o-ring, until metal to metal contact and then just a teeny tiny bit tighter. I have never had one come loose.
    Long live the internal combustion engine!

  8. #7
    Banned qwerty's Avatar
    Join Date
    Jul 2010
    Location
    NW Tennessee
    Posts
    10,664
    The Yamaha o-rings fail quickly when engine temps are high, especially on the exhaust side. I use Viton o-rings and replace them every other change. Cheaper to buy in bulk from an industrial power supply than from Yamaha.




Sponosred Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Tappet Sounds
    By phatrat1 in forum Technical Help
    Replies: 24
    Last Post: 12-09-2018, 12:56 PM
  2. Oil leaking from crank case cover
    By MarcusPotts in forum Technical Help
    Replies: 18
    Last Post: 04-22-2015, 11:07 AM
  3. tappet nut came loose
    By greendub in forum Technical Help
    Replies: 4
    Last Post: 04-29-2013, 08:32 PM
  4. Front sprocket cover leaking badly
    By Beewerks in forum Technical Help
    Replies: 10
    Last Post: 12-04-2011, 03:45 PM
  5. Oil filter cover leaking
    By junk munk in forum General Discussion
    Replies: 2
    Last Post: 10-25-2011, 12:15 AM

Search tags for this page

oil leaking from exhaust tappet cover

,

tw200 tappet o-rings

Click on a term to search for related topics.