2015 tw200 cam
Close
    
    
Results 1 to 3 of 3
Like Tree8Likes
  • 1 Post By twran
  • 4 Post By Purple
  • 3 Post By twran

Thread: 2015 tw200 cam

  1. #1
    Junior Member twran's Avatar
    Join Date
    Jun 2017
    Posts
    23

    2015 tw200 cam

    Hi guys.
    I got a 2015 tw it has 12,221 miles I had to replace the cam and rod in it.
    The oil was always at the level it should be. I ride it at 55-60 mph.
    The baffle screw broke an the baffle came out had to ride home for about hr with no baffle in.
    Could that have done that to the cam?
    Badgerflorida likes this.

  2. #2
    Super Moderator Purple's Avatar
    Join Date
    Mar 2015
    Location
    Ynys Môn
    Posts
    4,641
    It’s usually fitting the wrong type of oil filter …..

    As for the baffle spontaneously ejecting - you’re lucky – most of us can’t get that thing out using a tree, a length of rope, and a pickup truck …..
    (Warning - Forum may contain nuts) ...... Hidden Content

    TW200 - 1998 - Japanese import - 7000 miles on the clock - TW225 Special Edition 2007
    - Hidden Content

  3. #3
    Junior Member twran's Avatar
    Join Date
    Jun 2017
    Posts
    23
    LOL Yeah I am surprised it came out that easily

Sponosred Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Cam measurements - late model tw200
    By JerseyJeeper in forum Technical Help
    Replies: 7
    Last Post: 06-11-2016, 09:43 AM
  2. Replies: 14
    Last Post: 04-25-2016, 05:12 PM
  3. 2015 tw200
    By jgaff in forum TW200 Pictures / Videos
    Replies: 1
    Last Post: 05-28-2015, 05:44 PM
  4. 2015 tw200
    By Jeffge in forum General Discussion
    Replies: 42
    Last Post: 11-06-2014, 07:21 AM
  5. What do you think of the 2015 TW200?
    By dgclassic in forum General Discussion
    Replies: 6
    Last Post: 06-25-2014, 05:54 AM