Noisy engine head
Close
    
    
Results 1 to 5 of 5
  1. #1
    Junior Member yawabala's Avatar
    Join Date
    Aug 2012
    Location
    Nairobi, Kenya
    Posts
    22
    Hi guys,

    I recently had my T-dub piston rings replaced after it started burning huge amounts of oil.I also installed a stock exhaust system at about the same time since it had been riding for about 5 months without any silencer.It has improved ten fold ever since.Problem is,i've noticed annoying noises coming from the top of the engine.is it the engine head?).Any help?

  2. #2
    Senior Member tw200sgp's Avatar
    Join Date
    Mar 2012
    Location
    Singapore
    Posts
    258
    Quote Originally Posted by bala View Post
    Hi guys,

    I recently had my T-dub piston rings replaced after it started burning huge amounts of oil.I also installed a stock exhaust system at about the same time since it had been riding for about 5 months without any silencer.It has improved ten fold ever since.Problem is,i've noticed annoying noises coming from the top of the engine.is it the engine head?).Any help?


    Cam chain, tappets or maybe something else...i.e. cam shaft bearing wear Tappets are easily adjusted. Cam chain can be replaced. Cam shaft / head wear is not good (maybe results in new head). Are you sure it's not the con rod or pin?



    Make sure your getting oil in the head - there is small bolt on the right hand side you can slight unscrew while the engine is running - oil should come out of it. See owners manual or tech manual on this forum for info.

  3. #3
    Senior Member r80rt's Avatar
    Join Date
    Sep 2011
    Posts
    2,431
    If you've been running without a muffler, you may just be hearing normal engine sounds that you couldn't hear before.
    Only a fool would attempt it, and God help me, I am that fool!

  4. Remove Advertisements
    TW200Forum.com
    Advertisements
     

  5. #4
    Senior Member tinman tim's Avatar
    Join Date
    Jan 2012
    Location
    northeast ohio
    Posts
    503
    another concern is oil filter. Has this been replaced recently? Did the right one get used? The correct filter has the 4 holes in it (check sticky). 'Wrong' filter starves valvetrain of oil. TIM
    SeatConcepts,carb mod,Shinko tires,15/50 o-ring chain,custom racks f/r, aluminum luggage,windshield,handguards,heated grips,Clarke tank,high frt fender,led running lights,folding shifter, wide pegs,12v outlets,headlight kill switch,voltmeter,stainless header,2nd brakelight,GPS/phone mount

  6. #5
    Junior Member yawabala's Avatar
    Join Date
    Aug 2012
    Location
    Nairobi, Kenya
    Posts
    22
    thanks guys for the helpful info.

Sponosred Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Head gaskets
    By elime in forum Technical Help
    Replies: 4
    Last Post: 02-09-2013, 09:40 PM
  2. cylinder head
    By ldw72120 in forum Technical Help
    Replies: 7
    Last Post: 11-03-2011, 08:09 AM
  3. cylinder head
    By christddel in forum Technical Help
    Replies: 2
    Last Post: 02-28-2011, 04:38 PM
  4. Cam Slop in Head
    By rhanson94 in forum Technical Help
    Replies: 4
    Last Post: 01-31-2011, 06:15 PM
  5. Getting ready to head out
    By goldenhtr in forum Trails, Off-road, and Adventure Riding
    Replies: 12
    Last Post: 09-13-2010, 12:00 AM