No Power (electrical)
Close
    
    
Results 1 to 3 of 3
  1. #1
    Junior Member Beardwacker's Avatar
    Join Date
    Nov 2018
    Posts
    6

    No Power (electrical)

    I was wiring up my new pro cycle led taillight and it a guessing game on which wires go where. Anyway, when I turned the key on and hit the brake, all power went out. Is there a main fuse somewhere that I should be looking for. Thanks

  2. #2
    Senior Member Fred's Avatar
    Join Date
    Dec 2011
    Location
    Turtle Wrangling the Sierras
    Posts
    19,045
    Fuse is located behind right side side panel next to tool kit.
    Older models have only one glass tube type fuse, while new generation TWs have one blade type in service with a spare fuse stored next to it. Wow, product evolution!
    Good idea to have a few spare fuses on hand.
    These days there is such good customer service available that calling ProCycle for wire clarification might help.
    2003 TW200 "Betty Boop"
    2006 TW200 "Nibbler", a.k.a. “Mr.Gizmo"
    Hidden Content All Things Considered I’ld Rather Be Motorcycling

  3. #3
    Junior Member Beardwacker's Avatar
    Join Date
    Nov 2018
    Posts
    6
    Got it corrected, thanks
    Fred likes this.

Sponosred Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. No electrical power to anything
    By dbardell in forum Technical Help
    Replies: 9
    Last Post: 10-12-2018, 06:51 PM
  2. 2013 TW: No electrical power
    By bnjnz in forum Technical Help
    Replies: 7
    Last Post: 04-16-2017, 10:54 AM
  3. Help! Lost electrical power - NO LIGHTS!
    By the-wild-man in forum Technical Help
    Replies: 4
    Last Post: 07-14-2012, 07:44 AM
  4. No electrical on '87 after battery tender...
    By VitaBrevis in forum Technical Help
    Replies: 5
    Last Post: 01-19-2012, 07:17 PM