Installed JNS Headlight. Noticed that high beam indicator is not working. Related?
Close
    
    
Results 1 to 7 of 7
Like Tree6Likes
  • 1 Post By TheRustyNutz
  • 1 Post By Badgerflorida
  • 2 Post By RaZed1
  • 1 Post By TheRustyNutz
  • 1 Post By TheRustyNutz

Thread: Installed JNS Headlight. Noticed that high beam indicator is not working. Related?

  1. #1
    Junior Member TheRustyNutz's Avatar
    Join Date
    May 2019
    Location
    Charlotte NC
    Posts
    4

    Installed JNS Headlight. Noticed that high beam indicator is not working. Related?

    I just purchased a 14 TW and installed the JNS headlight. I noticed last night that the high beam indicator does not work. Is this related? I haven't even tried to troubleshoot yet..
    Darth likes this.

  2. #2
    Senior Member Badgerflorida's Avatar
    Join Date
    Jun 2017
    Location
    Milwaukee, WI
    Posts
    1,208
    If it’s the dash light that’s not working it’s quick and easy to test the bulb. Remove the two screws and swap with the neutral bulb. It could be related to your JNS install but I’d check the bulb first since it’s so easy. There might be a metal post on the bottom of the assembly with a cotter pin that you have to remove, but I think that’s only on the back of the speedo assembly, not the indicator assembly.

    I’ve had to replace quite a few of those bulbs, so I’m now replacing them with cheapo LEDs.

    And welcome to the forum!
    Last edited by Badgerflorida; 05-22-2019 at 08:06 AM.
    Darth likes this.
    01 street 203/204
    96 hybrid Shinko 241/428
    89 restored SOLD

  3. #3
    Senior Member RaZed1's Avatar
    Join Date
    Oct 2015
    Posts
    252
    The high beam indicator works on mine even with no headlight plugged in so I doubt the headlight is to blame. It's a little 194 automotive bulb. Super cheap/generic. You can get LED replacements for like a buck online. If you do, match the LED to the indicator color (so for high beam, get a blue LED neutral get a green one). White leds behind a colored lens tend to wash out and you get a "sunburst" look.
    Purple and Darth like this.

  4. Remove Advertisements
    TW200Forum.com
    Advertisements
     

  5. #4
    Junior Member TheRustyNutz's Avatar
    Join Date
    May 2019
    Location
    Charlotte NC
    Posts
    4
    Yea i will pull it apart but thought I would throw it out there while at work daydreaming about riding..
    Sthrnromr likes this.

  6. #5
    Senior Member Sthrnromr's Avatar
    Join Date
    Oct 2018
    Location
    Rural, South Carolina
    Posts
    630
    Ha! If you live in Charlotte, hopefully we can ride some dirt together at some point. Also, welcome to a great group and a great bike.
    2010 TW200 - The Goat
    Triumphs
    ATVs
    Way too many past bikes to list

  7. #6
    Junior Member TheRustyNutz's Avatar
    Join Date
    May 2019
    Location
    Charlotte NC
    Posts
    4
    Quote Originally Posted by Sthrnromr View Post
    Ha! If you live in Charlotte, hopefully we can ride some dirt together at some point. Also, welcome to a great group and a great bike.
    Yeah I sometimes go to CAW on my KTM. Gotta believe the TW can handle that place.
    Sthrnromr likes this.

  8. #7
    Senior Member tylermoney's Avatar
    Join Date
    Mar 2019
    Location
    Austin Tx
    Posts
    160
    Hmm. I ordered the JNS replacement LED headlamp and it was very simple plug and play for everything to work. The only thing with the JNS that would require other mods is the daytime running light—requires you to put in a switch.
    2019 Yamaha TW200
    - DG Slip On
    - Custom Oil Cooler
    - Manracks Seat Rack
    - Ricochet Skid Plate
    - Oversizzed Footpegs
    - Cycra ProBend Handguards

    1973 Yamaha RD350
    - In pieces in my garage Hidden Content

Sponosred Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Wtb: indicator, high beam, horn switch cluster
    By timberfalls in forum TW200 Classifieds
    Replies: 3
    Last Post: 05-30-2017, 07:30 AM
  2. High Beam Indicator
    By Rider21 in forum Technical Help
    Replies: 6
    Last Post: 08-29-2016, 05:49 PM
  3. 2015 Neutral Indicator NOT WORKING!!
    By NeilHook in forum Technical Help
    Replies: 14
    Last Post: 05-25-2015, 04:40 PM
  4. High Beam Indicator Doesn't Light
    By KS4TI in forum Technical Help
    Replies: 5
    Last Post: 05-03-2015, 04:45 PM
  5. Replies: 3
    Last Post: 03-16-2013, 08:08 AM