Choke off - Fast idle ~ at times
Close
    
    
Results 1 to 3 of 3
Like Tree1Likes
  • 1 Post By TW_in_BC

Thread: Choke off - Fast idle ~ at times

  1. #1
    Junior Member BryanB's Avatar
    Join Date
    Aug 2018
    Location
    Gunnison, Co
    Posts
    6

    Choke off - Fast idle ~ at times

    2019 - 100% stock

    Occasionally my 2019 has a fast idle like the choke is on, but it's not. In fact one time when I noticed this I pulled the choke to the full on position and the idle slowed down to a more normal level. Before I started messing with something I wanted to ask for advice from the experts. Maybe I should take it back to the dealer but their service department doesn't have the greatest reputation.

    I live in Colorado at 7,700 feet and some rides have taken me a little over 11,000 feet if that matters.

    Thanks in advance for any advice offered.
    2019 TW200 (Mine) 2017 TW200 (Wife's)

  2. #2
    Senior Member TW_in_BC's Avatar
    Join Date
    Jul 2010
    Location
    BC
    Posts
    665
    If it is new...I would take it back to the dealer.
    In the meantime, check to see if your cables are binding...ie: does this happen when you turn the bars from one side to the other, or is it just a random occurrence?
    MtnMan75 likes this.
    2008 TW200
    Southwest corner of BC Canada

    YouTube channel: Hidden Content

  3. #3
    Senior Member Ski Pro 3's Avatar
    Join Date
    May 2014
    Location
    El Dorado, California
    Posts
    802
    I've experienced similar symptoms due to a lean condition. The choke gets the mix a bit more rich and idle returns.
    The bear slayer!

Sponosred Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •