Odometer is out of whack.
Close
    
    
Results 1 to 9 of 9
  1. #1
    Junior Member inhousebob's Avatar
    Join Date
    Feb 2013
    Location
    Northern VA
    Posts
    16
    Hi all,

    My daughter has ridden about 100 miles on her TW and the odometer shows nearly 2400 since the last fillup. The trip odometer shows 92. Any ideas?

    Thanks,

    Bob

  2. #2
    Junior Member gussy78's Avatar
    Join Date
    Mar 2013
    Location
    Northern Indiana
    Posts
    24
    Bump! Is it brand new?
    '89 TW dark on light blue

  3. #3
    Junior Member inhousebob's Avatar
    Join Date
    Feb 2013
    Location
    Northern VA
    Posts
    16
    Quote Originally Posted by gussy78 View Post
    Bump! Is it brand new?
    Nope. It showed about 350 miles when we got it from a used bike dealer. Runs fine, in clean condition, just this odometer thing. I'm baffled. Maybe it got screwed up while they were rolling it back?

  4. Remove Advertisements
    TW200Forum.com
    Advertisements
     

  5. #4
    Senior Member n2o2diver's Avatar
    Join Date
    Jun 2011
    Location
    Dothan, AL
    Posts
    1,715
    Quote Originally Posted by inhousebob View Post
    Nope. It showed about 350 miles when we got it from a used bike dealer. Runs fine, in clean condition, just this odometer thing. I'm baffled. Maybe it got screwed up while they were rolling it back?
    That was my first thought!
    Hidden Content

    2005 TW200 (SOLD)
    2013 DR650

  6. #5
    Junior Member gussy78's Avatar
    Join Date
    Mar 2013
    Location
    Northern Indiana
    Posts
    24
    How would someone prove something like this? An old electrician I used to work with, somehow found out his car was an old demo model and had the odometer rolled back. This was years ago. He went to them with whatever proof he had and told them he was going to go to the local news. He ended up with a brand new trade in every three years!
    '89 TW dark on light blue

  7. #6
    Member craigerk's Avatar
    Join Date
    May 2011
    Posts
    54
    My tripometer (im sure odometer too, but noticed the trip right off the bat) is doing sort of the same thing right now. I think it has to do with my loose speedo cable though. Ever since my cable started falling out my tripometer jumps to like 200+ an I know I've only gone like 15 miles. It's falling out because the beveled edge the nut grabs is worn so much it sometimes pulls though.

  8. #7
    Junior Member inhousebob's Avatar
    Join Date
    Feb 2013
    Location
    Northern VA
    Posts
    16
    Quote Originally Posted by craigerk View Post
    My tripometer (im sure odemeter too, but noriced the trip rigjt off the bat) is doing sort of the same thing right now. I think it has to do with my loose speedo cable though. Ever since my cable started falling out my tripometer jumps to like 200+ an I know I've only gone like 15 miles. It's selling our because the beveled edge the nut grabs is worn so much it sometimes pulls though.
    I'll go and check it out. Thanks for the input!

  9. #8
    Junior Member inhousebob's Avatar
    Join Date
    Feb 2013
    Location
    Northern VA
    Posts
    16
    Quote Originally Posted by inhousebob View Post
    I'll go and check it out. Thanks for the input!
    I'm back. No obvious thing wrong with the odometer cable or its connection to the wheel. Any other thoughts?

  10. #9
    Senior Member Swamp's Avatar
    Join Date
    Apr 2013
    Location
    Michigan Territory
    Posts
    108
    Well, it is a mechanical devise, and it can fail! I'd take it back to the dealer where you bought it and show them! They should have papers on file when you purchased it showing the correct mileage. Not sure what can be done about it other then the dealer ordering a new odometer and setting it to the correct mileage if possible. But I do know that any dealer sellng a vehicle with an odometer that's messed up can lead to legal issues.



    I'm sure they would take care of the issue! But dont wait, get it back to them ASAP!
    Swamp

    2006 TW200

Sponosred Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. WTB - trip odometer reset knob
    By Neo in forum TW200 Classifieds
    Replies: 9
    Last Post: 12-27-2018, 10:51 AM
  2. Speedometer/Odometer light went out?
    By ARAYA90 in forum Technical Help
    Replies: 10
    Last Post: 06-14-2013, 02:16 PM
  3. Digital Speedometer/Odometer
    By Justin5117 in forum Performance and Customization
    Replies: 8
    Last Post: 11-20-2012, 06:45 PM
  4. Best way to add an odometer?
    By Rohnsman in forum Technical Help
    Replies: 11
    Last Post: 06-24-2012, 05:10 AM
  5. Odometer knob
    By Polarpilot in forum Technical Help
    Replies: 5
    Last Post: 10-13-2011, 01:14 AM