Wanted 2nd generation CDI or somebody to test mine for me
Close
    
    
Results 1 to 7 of 7
  1. #1
    Member TY80A's Avatar
    Join Date
    Sep 2013
    Location
    upperville va
    Posts
    49

    Wanted 2nd generation CDI or somebody to test mine for me

    I think I have my weak spark condition diagnosed to the CDI by default. (my spark will only jump 2mm gap) I don't have a buddy with a 88-2000 cdi to swap in to test so I'd like to find a good CDI to buy.

    Thank you, amigos

  2. #2
    Super Moderator littletommy's Avatar
    Join Date
    Mar 2013
    Location
    Spokane, Washington
    Posts
    17,260
    here is a link for testing CDI's from Lizrdbrth:

    https://tw200forum.com/forum/technica...check-cdi.html

  3. #3
    Member TY80A's Avatar
    Join Date
    Sep 2013
    Location
    upperville va
    Posts
    49
    Thanks, that is a cool trick to monitor sparkification.

    My bike won't even cough or sputter but had spark. It was hard to tell if the spark was "strong" or "weak" so I built a little spark gap jump tester. I took a plastic cap from a gallon oil jug and used a couple of coarse thread screws. One screws into the bare spark plug lead and the other screws inward to adjust the spark gap. An alligator lead is hooked from that screw to engine ground. While cranking, one can see the spark jump across the gap against the black background.

    My spark only jumps 2mm and the manual specifies 6mm as the minimum, so I can say I have a weak spark. Just to test my crude tool, I set the gap at 6mm and tested it on another bike that runs. Spark jumped across the 6mm gap and even further, so I'm pretty sure my 2mm reading is abnormal.

    My stator ohms at 850 pulse coil, 750 source coil, 50 ohms third coil. I think these are ok but don't have the actual 2nd generation ignition specs.


  4. Remove Advertisements
    TW200Forum.com
    Advertisements
     

  5. #4
    Member TY80A's Avatar
    Join Date
    Sep 2013
    Location
    upperville va
    Posts
    49
    bump still need one...

  6. #5
    Senior Member elime's Avatar
    Join Date
    Jul 2010
    Location
    San Jose, CA
    Posts
    6,957
    I took my coil to the dealer and he tested it for me. I think it cost a couple of bucks. It was OK.

    The spark on my TW looks very weak too. I doubt it would jump 6mm but the bike runs fine.

    Try pouring a little gas in the spark plug hole and starting it. If it runs it isn't the spark (though if it doesn't run it could still be the spark plug.)
    Last edited by elime; 10-07-2013 at 04:52 PM.
    Long live the internal combustion engine!

  7. #6
    Senior Member elime's Avatar
    Join Date
    Jul 2010
    Location
    San Jose, CA
    Posts
    6,957
    Did you try to start it? Anything happen?
    Long live the internal combustion engine!

  8. #7
    Member TY80A's Avatar
    Join Date
    Sep 2013
    Location
    upperville va
    Posts
    49
    She is still dead.

    I found a cdi on ebay and it ran great. My bike was missing the harness to the tail light and when i added it, i connected the tail light wire into the brown CDI wire instead of the brown tail light wire. This had no effect until i installed a tail light and was testing the plug back there. It ran and started great, allowed me to get the carb spot-on. Then I put it back on the lift to install a tail light.

    I tested the running light lead with a test light and found no power back there which led me to my mistake. I switched the connection to the correct wire but i guess that grounding the brown cdi wire through the test light with the key on was enough to fry the replacement cdi since I now have zero spark.

    i can plug my old cdi back into it and get the same weak spark as i did initially and my stator still ohms out the same as before.

    these CDI are made out of glass...

Sponosred Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Got mine back together
    By wrstlr119 in forum General Discussion
    Replies: 5
    Last Post: 04-18-2013, 06:55 AM
  2. new mexico bike (not mine)
    By peruano in forum TW200 Classifieds
    Replies: 2
    Last Post: 12-19-2012, 10:45 AM
  3. DIY Power Generation
    By operose in forum Off-Topic
    Replies: 14
    Last Post: 05-23-2012, 09:46 PM
  4. Camera Tank Mount - The Next Generation
    By B-dub in forum Performance and Customization
    Replies: 9
    Last Post: 01-11-2012, 06:17 AM
  5. Got mine
    By Ferd30 in forum General Discussion
    Replies: 3
    Last Post: 04-28-2011, 07:41 PM