TW200 Forum banner

idle

  1. Revs holding at idle - Help with next steps.

    Technical Help
    So my 2005 has 550 miles on it now, about 200 are mine. I'm in Idaho, elevation ~2,500 ft and plan to ride up to 6,000 often. When I first got it, I noticed the revs would hold at idle and it made riding pretty stressful, especially on city streets. I changed the air filter, oil, oil filter...
  2. Looking for ideas and solutions. Please help if you had similar problems.

    Technical Help
    I bought a 1996 TW200. Odometer reads 1650. Battery was dead and replaced. Throttle rusted and froze. I freed the throttle. Compression is 140psi cold. Fuel system is clean and fresh. I did not run it before bringing it home. My bad. I started it up with the choke full out. It ran very fast and...
  3. '94 TW200 not returning to idle

    Technical Help
    Hey everybody, I'm 19 years old and a first time TW owner. Just bought a 1994 TW200 in amazing condition with 940 miles on it. Sat for 15ish years with sparse maintenace from what I was told. When we brought it home, it would run very poorly at idle but was able to take a spin around the yard...
  4. Bike idling funny as well as the neutral light doesnt work.

    Technical Help
    I bought a 2004 TW around a 1.5 years ago. The original owner had the bike sitting for a very long time, when I picked it up it only had around 4700 miles on it. The neutral light used to work fine when I first got it, then stopped working about a month. I didn't think much about it as I knew...
  5. High idle after first ride....

    Technical Help
    So i took it for its first 12 mile run, the first 12 that bike has seen. I let it warm up, just tooled around the neighborhood shortly, then ran some back country roads. It idled fine during warm up, but after getting back, just sitting there the idle seemed quite a bit higher then when it was...
  6. 1987 TW200 - Absolutely no response to throttle at all

    Technical Help
    Hello guys, About two weeks ago, my 1987 was running fine at about 72-75mph on the highway when it suddenly lost power. I couldn't get it restarted and had to tow it home. I went over everything with a fine tooth comb and couldn't figure out what the problem was. After it sat for a few days...
Top