TW200 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi, picked up a new TW last week. Fun!

I'm hearing a strange noise when accelerating that sounds like a little something flapping around. I don't think it's the engine knocking. I'll have the service department check it out at 600 miles but they thought what I might be hearing is an emissions valve (or something like that) which is normal. Any thoughts?

I have some other questions but I'll post them separately to keep the threads topic specific.

Thanks
Dan
 

·
Registered
Joined
·
5,870 Posts
Hi Dan, and welcome to the forum!

I don't know what is causing the noise that you are hearing, but I can assure you that it is not an emissions valve since the TW does not have such a thing. I will be interested to hear what your dealer's service department says, but be forewarned that these engines are notoriously noisy - best described as a bucket of bolts trying to self destruct at higher rpm's.

Where are you located?

Brian
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
Hey Brian I'm in Wilmington Delaware.

Bucket of bolts lol! I put her up on a milk crate and started poking and shaking things around. I think something is rattling. Could be the skid plate, which I zip tied the rear attachment point tight. I found a couple of other possible suspects which I'll address after going for a short ride this evening to see if noise persists.

Thanks for the info!
Dan
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
Done!

The droning/rattling may be exhaust related. I'll get my buddy to ride it see what he thinks, he's good at this stuff. Little faith in dealer...
 
1 - 5 of 5 Posts
Top