TW200 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter #1 (Edited)
So I got brand new engine bolts and gaskets in the mail yesterday. Got the DT all ready to reassemble and fire up. Then I realized the SPROCKET (misleading title) cover is being blocked by the clutch push rod and wont sit flush against the case. Anyone know what I did wrong? Do i just need to force the push rod back in? Not sure how to proceed. Thanks!

CaseCoverwtffff.jpg

wtfffff.png

Some pictures of what is the issue.
 

·
Registered
Joined
·
821 Posts
Never great idea to force anything. Force best left to Yoda, he is far better equipped to handle it. Look to what pushes the rod on the other side, most likely where clutch cable attaches. The light in your head should come on and you will be blessed with enlightenment. Do not glue the gasket on or you face a visit from God of crap when next your there disassembling. Light tack on case only.
 

·
Registered
Joined
·
1,186 Posts
Have you tried to push the rod in with your thumb?
 

·
Registered
Joined
·
118 Posts
Discussion Starter #4
Yes, I've tried pushing it in with light pressure. Doesn't budge. I THINK that the push rod is being blocked by something. It should push in a bit to open the clutch I believe. I think my next step will be to take the clutch plates off and investigate that side of things.
 

·
Registered
Joined
·
2,494 Posts
I think you might have to rotate the pushrod a certain way before it can be pushed in?
 

·
Registered
Joined
·
118 Posts
Discussion Starter #6
I haven't messed with the push rod or clutch at all. Just removed covers to replace gaskets. One forum said that a plate could have slid down and is now blocking the pushrod. I am just now about to go back into the shop and start fooling around more.
 
1 - 6 of 6 Posts
Top