TW200 Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter #1
age and mild rust busted the tab off at 1800 miles. anyone use one of those Ricochet Clamp-on Kickstands before i have this welded back on? im thinking of getting one for a small CC bike like a yz80.







 

·
Registered
Joined
·
1,533 Posts
"Age and rust" on a '97 with just 1,800 miles ??? Is that what Kansas humidity can do? My old '93 with 11K has hardly any rust. But then the "high desert" climate in Idaho with almost no humidity is kind to my bike and I keep it in the garage in the winter. Can't say though how the previous owner(s) treated it. It does have signs that it may have spent some time stored outdoors.
 

·
Registered
Joined
·
116 Posts
Discussion Starter #3
"Age and rust" on a '97 with just 1,800 miles ??? Is that what Kansas humidity can do? My old '93 with 11K has hardly any rust. But then the "high desert" climate in Idaho with almost no humidity is kind to my bike and I keep it in the garage in the winter. Can't say though how the previous owner(s) treated it. It does have signs that it may have spent some time stored outdoors.


rest of the bikes frame looks fine, probably just from the previous owner off-roading with it. im going to call around and find a welder on monday, alot easier than trying to make that swingarm kick stand workout
 

·
Registered
Joined
·
1,302 Posts
If you can get it welded somewhat easily, that might be a better route. I've never seen those clip-on deals though. The bolt that holds my spring has a snapped head and it's a bit small to drill and retap all while the bike's in one piece. Honestly, if the Ricochet thing would fit, that would be kind of handy.
 

·
Registered
Joined
·
614 Posts
If you go the welding route remember to disconnect your battery and CDI or else they may go pop.



You can't get much worse conditions for rust than here by the southwest coast of the UK and I am very surprised that just rust caused this breakage. Sitting on the bike with it on the stand is more likely.
 

·
Registered
Joined
·
116 Posts
Discussion Starter #7
was planning on disconnecting as much as i can, i just put on a $240 cdi a few days ago and would hate to see it go up in smoke




when i line up the busted tab to the frame you can see there was a gap leftover, i bet water has been sitting in it forever.
 

·
Registered
Joined
·
168 Posts
most likely wasn't welded on very well from the factory worse things have happened but here in upstate ny where the humidity is above 70% most of the time things seem to rust fairly quickly not sure of the level around you
 

·
Registered
Joined
·
116 Posts
Discussion Starter #9
kickstand back in action. bought a Northern Industries 125 Flux-Core Welder for $190 shipped. i was expecting horrible results since there is no gas needed for this welder but i was pleasantly suprised. just throw away the demo wire they give you and pick up some Lincoln .035" wire from lowe's.
 

·
Registered
Joined
·
1,165 Posts
Glad you got it fixed and found another reason to buy a new tool. You will probably have a lot of fun with that.
 
1 - 10 of 10 Posts
Top