TW200 Forum banner

21 - 23 of 23 Posts

·
Registered
Joined
·
322 Posts
That's not correct action. If that's a normal new 2019 I'd bet the bushing that the basket rides in had changed or the pivot shaft or the bushing it rides in is but the correct tolerance.
If they "wear in" then it's a manufacturing tolerance issue. Neither of those sound like it's a cable issue. You can disconnect the cable and manually move the lever on the case. If it's still notchy I'd definitely take it back and discuss it with the dealer.
 

·
Registered
Joined
·
28 Posts
My 2019 which I just bought new at the end of December is the same way toward the end of engagement. I'm not sure if its the cable or a tight clutch arm bushing (In the case). Its been to cold to investigate it to any degree (Pun not intended). I've been collecting farkles for it and I'll try lubing the cable and clutch pivot when I change the handlebars. If its the bushing in the case, I'm fairly confident that it will smooth out with some use. Seems like a batch of 2019 parts may be on the tight side or the cable are just dry??? Will find out when the weather warms up a bit.
 

·
Registered
Joined
·
124 Posts
Here's a full post about it, I have a 19 and started with the same problem... it does need to wear in, it took about 100mi before I stopped noticing it, but mine would get worse the longer I rode initially.


It does get better though, make your cable adjustments and get that sucker lubed up good.
Yeah remember use “ plenty lube !!! “ on clutch ??? On not on crotch :ROFLMAO: :ROFLMAO: :ROFLMAO: :ROFLMAO::ROFLMAO::ROFLMAO::ROFLMAO: Unless you feel inclined to do so🤪
 
21 - 23 of 23 Posts
Top