TW200 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
257 Posts
Discussion Starter #1 (Edited)
Well despite the utterly crappy weather this past weekend and the week leading up too (Heavy rain and freezing temps) I decided to ignore common sense and head up north with my buddies for a day of off roading at one of my favourite trail networks. The majority of the people coming we're in nice warm enclosed jeeps but there were also a few ATV riders and of course myself and one other on a bike a friend of mine on a Modded Yamaha YZ250F (now a 290).

I did bring along a go pro and got a little bit of footage but being i just got the cam i failed a bit at operation and wasted most my battery life before actually getting to the trails so the best vid I have is actually riding the road from were I set up camp into town for some breakfast. But alas here it is the TW splashing along the road with my amateur riding skills occasionally seeing my buddy fly far ahead on his YZ.

https://m.youtube.com/watch?v=8UrbVW5v6xQ

All I can say is despite being cold and soaked all day I had a blast and GOD I LOVE MY TW. Most of the trails were reallly washed out and lots of very deep water so for much of it I switched up to riding my wife's ATV (which I brought along to give it some use).
IMG_3472.JPG
IMG_3464.JPG
 

·
Registered
Joined
·
1,865 Posts
What fun and pretty wet. We are having weird weather for us a low formed right over SoCal which is unusual and then it snowed last night in local mountains. For May in San Diego that's crazy. 75 today after.
 

·
Registered
Joined
·
1,495 Posts
Aw crap Mike sorry I missed that. Had stuff going on that weekend. I would have loved to bring my TW and my truck. My truck just craves that muddy water.

Edit: I just watched the video.... awesome at 12:30 how you just flew by that YZ like he was standing still...did you put NOS on that TW?
 
1 - 6 of 6 Posts
Top