TW200 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Here's a pic of the girls in the driveway the day after we got them.
A bit shiny and new, but we will get some of that shiny off shortly.

Have ordered cycle racks, power mad hand guards, Jimbo shields, handlebar risers and skid plates.
Will add pics as the bits arrive.

TWs new home.jpg
 

·
Registered
Joined
·
309 Posts
How are they running? I had to adjust my clutch and it needs to be on choke for a good 8 min to really be better. I think the idle is slightly low on my 2014.
 

·
Registered
Joined
·
422 Posts
Beauty - next weekend the weather should be good enough to get out for a tear and likely your Jimbo shields will be on and your hand gaurds too.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5 (Edited)
Ah, telling them apart?
That is quite a problem, but have ordered different coloured windscreens and hand guards, that should help. I don't want to look like twins, so will figure out a few more customizations.
I am wondering about getting my skid plate anodized and coloured.

They seem to be running fine fandango. I haven't noticed any clutch slipping. Mine does seem a smidge low on the idle, but want to live with it for a bit before I mess with anything mechanical.
 

·
Registered
Joined
·
63 Posts
My idle only seems low when it's still warming up after shutting the choke off, after riding it for a bit though and it gets fully warmed up the idle is much better... If after riding around I'm at a light for a fair amount of time I'll notice the idle drop down some more... But it's working fine so far
 

·
Super Moderator
Joined
·
17,941 Posts
My idle only seems low when it's still warming up after shutting the choke off, after riding it for a bit though and it gets fully warmed up the idle is much better...

This is normal, I wouldn't worry about it. A cold engine, friction and resistance until the oil is warmed up and the motor can move more freely.
 
1 - 9 of 9 Posts
Top