TW200 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Trying to install the SU rack--the first step prior to mounting aluminum panniers--from Happy Trails. Left side fit just fine. The right side has three secure points. 1) right blinker, 2) muffler bolt, and 3) top passenger foot peg. After securing the bolts on the blinker and muffler, the foot peg is about 1/4 to 1/2 inch off. Not sure what to do. Best pic I could get is enclosed. Suggestions?
 

Attachments

·
Registered
Joined
·
1,428 Posts
I wouldn't worry about it too much. That's the deal with metal fabrication, it's very difficult to get precise repeatable results. It is close, and I'm sure it will go.

First, I would remove the left passenger peg bolt and put some loctite on it, at least blue (med), red if you think you'll not likely remove it anytime soon. Reinstall it to finger tight then backing it out 1/2 turn so it's a little loose. Then, I would have all of the other bolts slightly loose, like the same half turn out from finger tight. Next, I'd use a ratchet strap(s) to crank things over to get the holes to line up. Also, a center punch, screwdriver, whatever to use as a drift pin type device to help line up the holes to get the bolt started can be helpful. Start that bolt, first put some loctite on it too, then torque it down. Release the straps, then go around and torque down the others. Done. Good luck.
 

·
Read Only
Joined
·
1,175 Posts
Mine didn't fit on the right side either. The bottom hole where the rear footpegs were didn't line up. I took a drill to it and turned the hole into a slot and it worked out just fine.

20170826_084500.jpg

20170826_084452.jpg
 

·
Super Moderator
Joined
·
5,169 Posts
There was an issue of the left and right rear foot pegs having a slight off-set on some year or another - don't quote me on that - but it comes as no surprise ......
 
1 - 4 of 4 Posts
Top