TW200 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
553 Posts
Discussion Starter #1
Gday folks.

My left blinkers haven't flashed for a long time, and I would now like to fix this.



What do I need a new one of, and where on the bike is it hiding? 1993 model.



Thanks Dubbers.



Rob.
 

·
Registered
Joined
·
1,305 Posts
Swap some bulbs first and see if that fixes anything. After that, flasher relay. It's on the left side of the headlight, hooked to the inner side of the cowl. If it's both lefts, clean/wiggle the connections at the relay rather than the relay itself. If no fix, test the wires from the blade (at the relay) to the lights themselves. If they check out fine, replace the relay.
 

·
Registered
Joined
·
7 Posts
My turn signals quit working all of a sudden about a month ago. Neither the left or right , nor front or rear worked. It was like the switch was doing nothing.

I created a small jumper to bypass the flasher/relay and when I would switch the left or right turn signal on; it would turn on, but not flash.

I removed the flasher and CAREFULLY removed the cover and cleaned the relay contacts inside with a small burnishing tool.

Put it all back together and it has been working fine ever since.

That save me the darn near $60.00 for a new relay.



So, If your right side turn signals are working, but not your left; it is not the relay and cleaning it as I described above will not help.

But I did take apart the turn signal switch as I was trying to fix my problem above, and maybe spraying a little electrical contact cleaner in there may help.

Or you are going to have to get a ohm meter and check for bad/open wires somewhere along the line.

Fred
 

·
Registered
Joined
·
553 Posts
Discussion Starter #4
Tip for my fellow electronically disadvantaged members; check your bulbs first, before you go and pull the cover off the relay and start mucking around......



Just say'n....
 
1 - 5 of 5 Posts
Top