TW200 Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
My 02 tdubs wires were cut. Headlight plug is gone and the keyswitch wires are cut. Does anyone have a oem like plug to rewire for my headlight bulb? And my wire colors are not exactly what i seen in the repair manual. Thanks for any help.
 

·
Read Only
Joined
·
173 Posts
H4 sockets are all the same. Looking at the female connecter with the slots in a U shape, the left is ground, the bottom is low beam, and the right slot is high beam. After you get your ignition switch fixed just use a voltmeter to distinguish the low and high beam circuits to be sure, but the common color coding should be ground - black, (or black/silver tracer on some), low beam is green and high beam is yellow. The high beam should also have a splitter on it with a line that goes up to your high beam indicator light which is also yellow. If there is any doubt to this (not the stock wiring setup... use a voltmeter and toggle the switch... either way though, if you have a high beam indicator lamp, it should led you back to the high beam wire).

These sockets are available online (mostly with wiring come straight out of the back... if you can find one where the wires come out at a 90 degree to the socket that would be ideal, but if all you can find is the straight wires - put a 90 on them as a group and heat shrink/tie wrap them into that position towards the wiring coming up the right side of the frame.)

The ignition switch - I still as of right now only have a diagram of a TW200T from online, and it shows a black/white going back to same on the CDI, a black wire that goes to chassis ground/battery negative which are both shown to be a completed circuit through the ignition switch when off. When turn on, there should be a red that meets up to a connector with the black, brown and red wire and then becomes red/white which then goes out to the regulator's red wire (not sure exactly where on your bike), and a brown wire that goes out to many other components on the same brown wire. Be careful about the shade of brown on that wire and match it exact with the others as the left flasher and turn indicator also use a different shade of brown wire. I hope this helps you out.

Distinguishing the two black grounds for both the light circuit and the ignition circuit - the black ground circuit for the headlamp will be in a connector along with the headlamp low/high and turn signals, but ground is ground either way. Just for the interest of keeping your harness traceable for future use I would stick with the way it was setup before and not swap these two if it can be helped.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4
H4 sockets are all the same. Looking at the female connecter with the slots in a U shape, the left is ground, the bottom is low beam, and the right slot is high beam. After you get your ignition switch fixed just use a voltmeter to distinguish the low and high beam circuits to be sure, but the common color coding should be ground - black, (or black/silver tracer on some), low beam is green and high beam is yellow. The high beam should also have a splitter on it with a line that goes up to your high beam indicator light which is also yellow. If there is any doubt to this (not the stock wiring setup... use a voltmeter and toggle the switch... either way though, if you have a high beam indicator lamp, it should led you back to the high beam wire).

These sockets are available online (mostly with wiring come straight out of the back... if you can find one where the wires come out at a 90 degree to the socket that would be ideal, but if all you can find is the straight wires - put a 90 on them as a group and heat shrink/tie wrap them into that position towards the wiring coming up the right side of the frame.)

The ignition switch - I still as of right now only have a diagram of a TW200T from online, and it shows a black/white going back to same on the CDI, a black wire that goes to chassis ground/battery negative which are both shown to be a completed circuit through the ignition switch when off. When turn on, there should be a red that meets up to a connector with the black, brown and red wire and then becomes red/white which then goes out to the regulator's red wire (not sure exactly where on your bike), and a brown wire that goes out to many other components on the same brown wire. Be careful about the shade of brown on that wire and match it exact with the others as the left flasher and turn indicator also use a different shade of brown wire. I hope this helps you out.

Distinguishing the two black grounds for both the light circuit and the ignition circuit - the black ground circuit for the headlamp will be in a connector along with the headlamp low/high and turn signals, but ground is ground either way. Just for the interest of keeping your harness traceable for future use I would stick with the way it was setup before and not swap these two if it can be helped.
As you said with the H4 connector. The slots In a U shape left yellow, bottom green, right has two brown comming from that slot.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #8
20190831_133346.jpg

By touching the blue and yellow to the blue and white it will run. I see a small black wire comming from that plug. Thats prob my head light ground? I know its ground from my multimeter. I have a solid black and a black and white tracer wire comming from my new switch. The have continunity when the switch is off, but when turned on they do not. And my odometer light is not comming on.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #12 (Edited)
20190831_200134.jpg

Shes runs great. Owner thought it was blowed up. Cleaned the carb and changed the gas out. Water in the gas was the problem. Pays to have a little mechanical skills.

Thank you everyone for taking the time to write very detailed messages. Those take time and effort to do. So, I just wanted to say thank you!
 
1 - 12 of 12 Posts
Top