TW200 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
After spending the last couple of weeks installing new sprockets, chain and a kick start on my 2006 I find myself ready to move onto replacing the front tire except for one issue. I do not think my kick crank is going on all the way. It won't go on any further than pictured due to the splines and I don't think I should have any shaft showing between the kick crank and the case. I have studied every post and picture I can find and I believe I have the right parts, I just cannot figure out what I am missing. If it wasn't for the fact that the kick starter would open into the bike I would think that the kick crank should be installed 180 degrees from the way it is pictured. Is it correct as pictured? If not any advice on what I am missing?

Thanks in advance.
 

Attachments

·
Super Moderator
Joined
·
1,920 Posts
I think I read that there is a plug that goes on the end of the crank to plug that hole you see. I'm sure TWLIGHT or TWBRIAN can say for sure.
 

·
Registered
Joined
·
6,059 Posts
Goldenhtr is right, Frisbee. There is nothing to worry about.

The TW kick crank boss does not slide all the way onto the kickstarter shaft. If you were able to get the bolt in and tightened, then you are good to go. There is a plastic plug available from Yamaha that covers this hole and helps to keeps dirt and water out of there, but it is mostly cosmetic.

Congrats on a successful installation!
 

·
Registered
Joined
·
28 Posts
Discussion Starter #4
Thanks guys. Just went out and put bolt in. Wish I hadn't second guessed this and done that before I put foot peg and break lever back on. Glad to be done with this.
 
1 - 5 of 5 Posts
Top