TW200 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter #1
Hello everybody, I just got a 2006 TW a couple days ago. Snowmobile season pretty much over so I thought I would get something to ride the trails up north in the summer, so I started searching and found this site and decided to get a TW. I have changed the oil/filter and adjusted the chain so far but I'm having trouble getting to the air cleaner, I took the side panel screws out but I can't get the front fastener to come out. It feels like I'm going to break or bend the panel, does it just pull straight out?
 

·
Registered
Joined
·
866 Posts
Do you mean one of the screws is stuck, or the panel is stuck after you take out the screws?



I'm thinking you've got the two screws loose from the side panel, and at the front of the side panel (almost where it is pointed at the front), there is a rubber grommet type connector to the tank. Look underneath the panel/tank, and you'll see what I'm talking about. Put your hand right around that area (as close around the grommet as you can) and pull straight out. It sometimes take a bit of a tug, but once you get the hang of it it's no problem.



I've put some pics below.



Tank Grommet





Side Panel Extrusion

 

·
Registered
Joined
·
84 Posts
Discussion Starter #3
Thanks Rodney, yes I took both screws out and tried to pull the front out, I pulled pretty hard but it didnt budge. I'll give it another try tonight.
 

·
Registered
Joined
·
866 Posts
Sometimes the thing gets broken and people will do stuff like wire or zip tie the panel. Look under there and see if that might be the problem. Also, if it hasn't been removed in a long time, don't be afraid to squirt some wd-40 or something in there onto the rubber if you can.
 
1 - 4 of 4 Posts
Top