TW200 Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
1990 with a cleaned carb,jetted and 3 washers under the needle and it runs the same as stock. On a small digital tach it just doesn't seem to want to rev much past 7400rpm's and 50mph without the stumble,bog that feels like a rev limiter kicking in , also in nuetral it will rev out nice and smooth till it gets around 6k then start to struggle. I'm starting to think it might be a coil pack or cdi ?
 

·
Registered
Joined
·
3,109 Posts
I believe the redline is 9500rpm.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
As i stated in the original post, the bike runs with the same problem on stock 114 jetting and stock needle position as well as 3 washaers and a 120 main. Not a rich issues as it is the same trouble either way .
 

·
Registered
Joined
·
106 Posts
As i stated in the original post, the bike runs with the same problem on stock 114 jetting and stock needle position as well as 3 washaers and a 120 main. Not a rich issues as it is the same trouble either way .
I had a similar problem and it turned to be a gas venting issue. I removed the tumblers from the tank cap( 2 screws) and that seemed to fix the problem.( I also like the fact you dont need a key to fill up.) Give it a shot you can always reverse the "fix." Also for those that have a tank bag , be sure you are not smothering the cap vent with the bag. I only say , cause I have.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #6
The cap vent was one of the first things I checked , I cleaned the tiny holes and if you turn the petcock on you get a ton of flow into a container so that is off the list, I ordered a aftermarket coil pack it try so for $20 it is a cheap test to rule the coil out .
 

·
Banned
Joined
·
10,664 Posts
Redline is 10,200 according to MCN article.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #8
Well no wonder this little bike won't go over 50mph I'm missing a couple thousand RPM's on the top end ,it won't go over 7500+or- a few hundred .
 

·
Registered
Joined
·
7,369 Posts
Has some joker childproofed your throttle stop?
 

·
Banned
Joined
·
10,664 Posts
Dirty air filter.



Critter nest in snorkel.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #17
Kwep jm coming ! The answer musg be out there , the new coul came in today so that will get tested tonight hopefully .
 

·
Registered
Joined
·
7,369 Posts
Have you verified your ACTUAL fuel level in the float bowl with clear tubing?



Checked the o-ring in the manifold and checked the manifold for cracked rubber?



Overoiled the filter or used heavy oil?



Define "stumbles". Does it just run out of power or start bucking like a bull?
 

·
Registered
Joined
·
2,105 Posts
Have you verified your ACTUAL fuel level in the float bowl with clear tubing?



Checked the o-ring in the manifold and checked the manifold for cracked rubber?



Overoiled the filter or used heavy oil?



Define "stumbles". Does it just run out of power or start bucking like a bull?




Gremlins????





Ronnydog
 

·
Registered
Joined
·
42 Posts
Discussion Starter #20
Ok the float level has been checked with the bowl off and in spec clear tube check has not been done due to a striped head drain screw , air filterhas been tried dry after cleaning and freshly litely oiled and not installed same outcome the bike bucks like a bull at wot . As for air leaks i have cranked up the idle to around 3k and sprayed the boots down with ether to see if there were any leaks , none found .
 
1 - 20 of 28 Posts
Top