TW200 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1
Greetings all. I removed my swingarm to replace a broken chain guard. When putting the swing arm back on I was only able to get one of the two thrust covers back on that go on in the middle of the swing arm and attach to the engine. Will I be ok riding on this until I can get a replacement thrust cover? Do I even need a replacement. Still feels pretty secure with one thrust cover.
 

·
Registered
Joined
·
8,371 Posts
When I had mine off for repainting it was tough getting it to go back on. I ended up using a thin putty knife on the right side to help guide the thrust cover in. You might also note that the right side, under the thrust cover has a shim or two while the left side does not. I can't honestly determine the purpose of the shim or just how necessary it or they are but I suspect it has to do with proper alignment. It seems like a tiny fraction but I put it back on just the way it came off with 2 shims. The thrust covers I am sure have importance and if they are missing there will be no way to keep the arm aligned and no way for the seals to keep the grease in. I would suspect the first time you grease the arm the seals would blow right out if no thrust cover is on that side.

GaryL
 

·
Registered
Joined
·
65 Posts
Discussion Starter #4
Thanks Gary. After reviewing the fiche again I figured out its actually the Collar 90387-125F1-00 X 2 on the Crankcase that I was having an issue getting back in. I realized this after ordering the wrong parts twice. I ordered two new ones and hopefully these will stay in place while I put the swing arm back on. The old ones are a little worn and fall out every time I try to put the swing arm back on.
 
1 - 5 of 5 Posts
Top