TW200 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
287 Posts
Discussion Starter #1
Most members of this forum are not aware of our sister forum that was started when this one went bust a couple of years ago. Almost all of the members are members of this forum also. Anyway, you may want to pay it a visit and support it some as a lot of work probably went in to it. I am by no means asking anyone to not support this one as it is our "bread and butter". Just letting you know!!!! The forum is located at tw200.forumotion.com

Thanks Guys
 

·
Registered
Joined
·
2,667 Posts
yea i remember going there when this site went down but i never joined...just joined today...now i have 3 places to get my fix (the 2 forums plus the tw200 thread on advrider)!
 

·
Registered
Joined
·
20,466 Posts
New to me also, thanks for the heads up
 

·
Registered
Joined
·
546 Posts
I just registered too but seems like it is un-responsive at the moment :(
 

·
Super Moderator
Joined
·
18,138 Posts
I used to look at that one, but there wasn't much activity like here, so I stopped looking over there. I do look at the TW thread in ADV rider about once a month.
 

·
Registered
Joined
·
2,667 Posts
I just registered too but seems like it is un-responsive at the moment :(
Did you activate your account from the email the forum sent you?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,667 Posts
I used to look at that one, but there wasn't much activity like here, so I stopped looking over there. I do look at the TW thread in ADV rider about once a month.
i'm pretty much the same way...but if i have a really slow day i'll probably go to all 3 now
 
1 - 8 of 8 Posts
Top