TW200 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2,439 Posts
Discussion Starter #1
Has there been an update on the TW which would lockup within a few miles of being driven?
What about the new member who port and polished the heads new big piston etc? I would like to know what fixed the issue or was there a great power improvement.
Something I noticed on mine is that when wound out at about 68mph it chugs for lack of fuel. A bigger jet didn't help performance. I think this is a fuel flow issue not a mixture issue. The Cornelius pumper carb may fix this. Is there a higher flowing petcock which might help or a bigger high flow float needle?
 

·
Registered
Joined
·
1,079 Posts
68 MPH level?
No wind?
Air filter clean?
Petcock screen clean?
Air inlet open?
Fresh spark plug?
Chain well lubed?
Tire pressure?

Guess I am better at questions than answers!
 
  • Like
Reactions: Ken and littletommy

·
Registered
Joined
·
2,439 Posts
Discussion Starter #6
68 MPH level?
No wind?
Air filter clean?
Petcock screen clean?
Air inlet open?
Fresh spark plug?
Chain well lubed?
Tire pressure?

Guess I am better at questions than answers!
No noticeable wind at the time. I was sitting upright not leaned at all.
Air filter is normal not recently cleaned.
I don't mess with the petcock screen since I Kreem lined the tank and there is no trash unless it is from the station. I have an inline filter also.
The air inlet is closed. I removed the baffle a while back tinkered some with the airbox but it did nothing to gain so I put the baffle back in and closed the airbox up tight.
Old spark plug. I only change them if it is running bad or the electrode looks worn or out of spec and I don't check that much since it runs great.
O-ring chain well lubed with sticky PJ1 Lube. I just spray more on and keep going unless I actually have dirt or mud on it.
Tire pressure is 18 frt, 22 rear.
I have the 49 tooth rear and the stock front sprockets.
I did try an xt225 cheap Chinese cam which results are still up for debate. Check out cheap Chinese cam on tw200 search. I rode 2 up with my daughter this weekend and was hitting about 62mph. My wife was griping that we took off and left her, she was following in the car and I stayed in one lane without maneuvering. After I dropped my daughter off I filled up with Citgo gas and actually hit 72mph on the way home sitting straight up. This is the 2nd time to hit 72 after filling up with Citgo gas that is ethanol tainted that is all we have. I forgot that the freeway right beside me has really bad crosswinds and an uphill ramp. Where I was riding today is uphill and downhill with normal winds. I do have the Tw203 and tw204 tires which helps with top speed. I am about 210lbs so it was pulling.
 

·
Registered
Joined
·
474 Posts
Something I noticed on mine is that when wound out at about 68mph it chugs for lack of fuel. A bigger jet didn't help performance.
Was it kind of like a hiccup, but just not all the time? Mine did that after bigger piston install. Went up a jet size and didn't help either. Ended up dropping one jet size and the seemed to help. Pull the plug and post a few pics.
 
1 - 7 of 7 Posts
Top