TW200 Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
13,795 Posts
Discussion Starter #1 (Edited)
Part I - TW200 Spring Ride in the Owyhee's

It's been a busy riding season and now that it's slowing down I'm catching up on some early season rides. With Mrs. Admiral this past spring in the Owyhee's on the Oregon/Idaho Border. We were able to ride some "cowboy singletrack". That's always fun.

Can't complain about camp


Spot some pre-historic pterodactyl tracks while out on my morning hike with Roscoe. Possible they are newer and made by some other kind of bird like create such as a crow 'er sump'in.


Roscoe taking to the hiking pretty well I'd say


Stopped at these old corrals near an old ranch we can't visit because of no trespassing sign. Gee-dang-it!


Later on we were gonna cross the creek but it looks like the creek has turned into a river. Not knowing how deep the water is and that it was flowing fairly swiftly, we turned around not wanting to chance it.


But not all is bad. We find some "cowboy singletrack" which leads us back out of the canyon a different way so we don't have to backtrack.
2.PNG

It was scenic and fun
5.PNG

Mrs. Admiral enjoying the "non-technical" cowboy singletrack
6.PNG

We end Part I at another swollen water crossing further down stream.
IMG_1226.JPG

Stay tuned for part II.
 

·
Registered
Joined
·
20,483 Posts
Really enjoyable video!
Pretty idyllic campsite too.
Looks like the cute couple were some of the few, if not the first visitors since any seasonal rains based on lack of tracks on those cow paths. Maybe I imagine a horse shoe print in front of Mrs.Admiral in the still photo?
Anyways that sure looks like fun exploring endless informal trails that take off and disappear over the horizon. Those critters have figured out the routes to water features and passes so why not follow them?
At least cows don't decide to have their trails suddenly leap over 2 foot ledges like the deer trails some of us have been known to pursue.:rolleyes:
 

·
Registered
Joined
·
13,795 Posts
Discussion Starter #4 (Edited)
Kris,
Response from Admin:
I see all of the photos, though this may have been edited based on the comments. Typically if the post is loaded with URL or Google image drives the thread needs a moment to cache the images before the poster can post. I will look into it further, keep an eye out to see if it this issue reappears and I will look into things on our end.

Once you see this Kris, I'll delete these posts that are not nessesary. Don't want to clog up your nice thread. I can see all the pics now except one??
Here is a test of some pictures from google to see if you can see them. Yes, the pictures in the thread above I reposted by attaching them from my computer instead of using the Google Photo host so that's why we can see them now.

Also of note is, when you can't see them, I can't see them on my phone either but I can on my computer. I think I can see them on my computer because it's what I used to post the pictures. Electrons, what can we say eh?

...and yes, you can delete our "I can't see the photo's" dialogue. But please, anytime you can't see the pictures let me know like you did here because apparently I can and won't know they're showing or not.

IMG_1230.JPG

IMG_1241.JPG

IMG_5820.JPG
 

·
Super Moderator
Joined
·
18,142 Posts
I can see all three of these pics.
 

·
Registered
Joined
·
13,795 Posts
Discussion Starter #6
I can see all three of these pics.
This is so weird. I posted them from Google Photos just like I did the first batch which didn't work. I can see them on my phone too. I guess I can also use my phone as a picture posted correctly checker since I have the same "can't see the photo" on my phone as some of you all.

Leave these pictures up a day or two to see if there is some kind of snafu. If you (we) can still see them on Monday, go ahead and kill the non-related posts.

Maybe the admins accidentally spilled some coffee (or 5 hour energy drink) on their keyboard and when they cleaned up the mess they hit the button which corrected the problem. Who knows.

Thanks for your help LT.
 
  • Like
Reactions: littletommy

·
Super Moderator
Joined
·
18,142 Posts
Remind me on Monday... :D

Those are beautiful pics btw.
 
  • Like
Reactions: admiral

·
Registered
Joined
·
20,483 Posts
I am getting “broken image” message for the last three pictures from Admiral’s post on my apple phone
 
  • Like
Reactions: littletommy

·
Registered
Joined
·
13,795 Posts
Discussion Starter #9
I am getting “broken image” message for the last three pictures from Admiral’s post on my apple phone
I can still see them here on my 'puter and on my phone. Quite breaking the images and you could see them. :p

Yeah, I don't get what the problem could be. Fixed in one regard and then someone else can't see it. Maybe it's politics. :D
 
  • Like
Reactions: littletommy

·
Registered
Joined
·
39 Posts
Well I can't see the later posted pictures but what I did see was enjoyable, thank you. My hat is off to Mrs. Admiral, Mo would not have enjoyed some of those narrow, rocky cow trails.
We lived in Eastern OR for many years and the country seems very similar to what you were riding in. Makes me a bit homesick.
Mikey
 

·
Registered
Joined
·
20,483 Posts
See very good photos of the land of milk chocolate pudding now from my laptop. Nice!
 
  • Like
Reactions: littletommy

·
Registered
Joined
·
13,795 Posts
Discussion Starter #12
TW200 Spring Ride in the Owyhee's Part II Ranch Ruins

We continue riding through the treeless forest...


...and some draws
1.JPG

...canyons
2.JPG

...hills
3.JPG

...creeks
4.PNG

...past dreams
5.PNG

...cowboy lakes
6.PNG

...and one last canyon
7.PNG
...before heading back to camp for the day
IMG_E1207.JPG

Good times...
8.PNG
 

·
Registered
Joined
·
3,366 Posts
all clear from my mac, looks like a great ride... spring.
 

·
Registered
Joined
·
13,795 Posts
Discussion Starter #14
TW200 Spring Ride in the Owyhee's Part III

...and then the floodgates from the skies opened up...

The final day of our Spring Owyhee adventure didn't quite go as planned.

We got caught in a couple rainstorms and the road turned to gumbo mud.
IMG_1234.JPG

We didn't get stuck in the mud. The mud got stuck to us. The mud even stuck to the foot of the kickstand.
IMG_1233.JPG

We got tired mucking around in the muckery.
IMG_1230.JPG

We got a little damp haha.
IMG_5833.JPG

It took us about 2 hours to get to the main road. We had to leapfrog past one another while cleaning out the mud from the sprockets/forks/fenders and swing-arms.
IMG_1236.JPG

...but we made it. Thanks a lot gumbo mud!!!
IMG_1242.JPG
 

·
Registered
Joined
·
166 Posts
Wow Admiral! I watched a couple of your youtube videos the other night and did not make the connection. I watch tons of TW200 youtube. Your videos were very good. Looks like a lot of fun out there. I recognized Mrs. Admiral's distinctive pink Tdub. That looked like a very cool ride in the Owyhee's. I subscribed your Klnrgj01 youtube channel. I also saw some Idaho Tdub youtube vids from LeisureTime Larry. I didn't realize just how beautiful Idaho is.
 
1 - 15 of 15 Posts
Top