TW200 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
i have a '87 tw that starts good, idles great , carbs rebuilt, but when it warms up it stutters , backfires and barks, and has trouble idling . if i let it cool down overnight it starts all over. could it be coils or cdi? my neighbour has the same tw , his runs great unless he lets it sit for 3 or 4 days than it wont start? if he runs it every day every thing is fine. what could be wrong. he won't let me try his cdi because he thinks i may blow his cdi with my bike problems.
 

·
Registered
Joined
·
2,516 Posts
How many miles?.....air filter clean and oiled?....has the bike been re-jetted?.Pet-cock "filter" clean?.
 

·
Registered
Joined
·
821 Posts
Well, how about putting your CDI into his bike? Then you'll know if it's your CDI! Can't harm your bro's CDI that way.

More direct would be to follow the wise sage's timing light method

for checking the CDI on this forum. Lotta good info on this site on the problematic '87 CDI
 

·
Registered
Joined
·
1,621 Posts
The curse of the 87s goes on.... I'd link you to the replacement 87 cdi thread but I don't know how to cut and paste with my tablet.
 

·
Registered
Joined
·
62 Posts
As far as the 87 that will not start if it sits. I had this problem a while back but it seems to have resolved itself after i cleaned the carb.. I quick work around was to drain the carb bowl and let it fill with fresh gas and it would start right up..
 
1 - 6 of 6 Posts
Top